aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-05-05 15:51:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-05-05 16:09:08 +0000
commit762aa0135a4e18d32bd27bba5266fe6edd769d82 (patch)
treeeae7a99f155fe768b3f8bf17f25e53ec37382c0a
parent01807ba27a0790623f2a3846dac25dd58be339bc (diff)
downloadports-762aa0135a4e18d32bd27bba5266fe6edd769d82.tar.gz
ports-762aa0135a4e18d32bd27bba5266fe6edd769d82.zip
Revert "www/chromium: Change default audio output to PULSEAUDIO to make chromium to play nice with desktop environments"
This reverts commit 89e432ced730385869e5bf6df4b705facbd1c947. Reason: Several people complained that the PulseAudio dependency is a lot heavier than Sndio. This is currently a controversial issue because: 1. PulseAudio is indeed a heavier dependency compared to Sndio, so for people who prefer minimalistic setup Sndio should be a default. 2. Currently desktop environments work best with PulseAudio, so it is better for average users to have PulseAudio as a default backend. It would be best if www/chromium would allow to change audio backend at-startup or on-the-fly without the need to change port options. This can be achieved by the following methods: 1. Flavorizing www/chromium based on audio backends. 2. Creating slave ports with different audio backends. 3. Implementing on-the-fly or at-startup setting of the audio backend. In https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=246449#c5 Robert Nagy <rnagy@FreeBSD.org> volunteered to implement audio backend dependency in a proper way. I've suggested that the item 3. above is a proper way for chromium. PR: 246449
-rw-r--r--www/chromium/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 5c289e69d791..9a2a287d8e19 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -1,6 +1,5 @@
PORTNAME= chromium
PORTVERSION= 124.0.6367.118
-PORTREVISION= 1
CATEGORIES= www wayland
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
https://nerd.hu/distfiles/:external
@@ -141,7 +140,7 @@ SUB_FILES= chromium-browser.desktop chrome
SUB_LIST+= COMMENT="${COMMENT}"
OPTIONS_DEFINE= CODECS CUPS DEBUG DRIVER KERBEROS LTO PIPEWIRE TEST WIDEVINE
-OPTIONS_DEFAULT= CODECS CUPS DRIVER KERBEROS PIPEWIRE PULSEAUDIO
+OPTIONS_DEFAULT= CODECS CUPS DRIVER KERBEROS PIPEWIRE SNDIO
OPTIONS_EXCLUDE_aarch64=LTO
OPTIONS_GROUP= AUDIO
OPTIONS_GROUP_AUDIO= ALSA PULSEAUDIO SNDIO