aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn W. O'Brien <john@saltant.com>2023-10-16 05:33:26 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-10-19 07:10:08 +0000
commit762e37327837dbc4ea55c0c22620fc05907e0c28 (patch)
tree02d6859adc4ebf232da2801e1ba36ca8b60d7bb4
parent7ece9bd58fe3a57952c3a97bc28323b0ff7bdbd6 (diff)
downloadports-762e37327837dbc4ea55c0c22620fc05907e0c28.tar.gz
ports-762e37327837dbc4ea55c0c22620fc05907e0c28.zip
security/lastpass-cli: ensure consistent OpenSSL usage
The recent change, switching security/openssl from 1.1.1w to 3.0.11 uncovered a latent bug in security/lastpass-cli, which always uses OpenSSL from base regardless of the ssl setting in DEFAULT_VERSIONS. With DEFAULT_VERSIONS+=ssl=openssl, the configure phase reports "Installing openssl-3.0.11,1" and subsequently -- Found OpenSSL: /usr/lib/libcrypto.so (found version "1.1.1t") This patch fixes the bug and ensures the same OpenSSL version is used throughout. PR: 274507 MFH: 2023Q4 (cherry picked from commit 76da322580253a6aaad9c9ec0fdc6a5427242865)
-rw-r--r--security/lastpass-cli/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/security/lastpass-cli/Makefile b/security/lastpass-cli/Makefile
index 211483000b59..2bc298d54abf 100644
--- a/security/lastpass-cli/Makefile
+++ b/security/lastpass-cli/Makefile
@@ -41,6 +41,8 @@ PINENTRY_RUN_DEPENDS= pinentry:security/pinentry
XCLIP_RUN_DEPENDS= xclip:x11/xclip
XSEL_RUN_DEPENDS= xsel:x11/xsel-conrad
+CMAKE_ARGS+= -DOPENSSL_ROOT_DIR=${OPENSSLBASE}
+
post-extract:
@${REINPLACE_CMD} -e 's/-Wno-language-extension-token//g' \
${WRKSRC}/CMakeLists.txt