aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2023-03-16 20:23:51 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2023-03-16 20:28:26 +0000
commit76506bc51ce83fc2796b7be4403f3f56c0fe9e42 (patch)
tree312b7ea2d62ddd2319d8843ae93d00f3db7e2e29
parent9fea31a78fc1889e8be8dc2ceaa6cc063adfe31e (diff)
downloadports-76506bc51ce83fc2796b7be4403f3f56c0fe9e42.tar.gz
ports-76506bc51ce83fc2796b7be4403f3f56c0fe9e42.zip
net/bird2: Update to 2.0.12
Due to some patches accepted in the upstream simplify port. Make the netlink flavor available for the upcoming 13.2-RELEASE and stable/13. Changelog: https://bird.network.cz/pipermail/bird-users/2023-January/016560.html PR: 269553 Reported by: Marek Zarychta <zarychtam@plan-b.pwste.edu.pl>
-rw-r--r--net/bird2/Makefile7
-rw-r--r--net/bird2/distinfo6
-rw-r--r--net/bird2/files/extra-patch-netlink31
-rw-r--r--net/bird2/files/patch-sysdep_bsd_sysio.h48
-rw-r--r--net/bird2/files/patch-sysdep_linux_netlink.c22
5 files changed, 6 insertions, 108 deletions
diff --git a/net/bird2/Makefile b/net/bird2/Makefile
index 9a23335cc348..6a154583c230 100644
--- a/net/bird2/Makefile
+++ b/net/bird2/Makefile
@@ -1,5 +1,5 @@
PORTNAME= bird
-DISTVERSION= 2.0.11
+DISTVERSION= 2.0.12
CATEGORIES= net
MASTER_SITES= https://bird.network.cz/download/
PKGNAMESUFFIX= 2
@@ -64,9 +64,8 @@ RPKI_LIB_DEPENDS= libssh.so:security/libssh
.if ${FLAVOR:U} == netlink
CONFIGURE_ARGS+=--with-sysconfig=bsd-netlink
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-netlink
-.if ${OSVERSION} < 1400073
-BROKEN=No netlink support
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1302000
+IGNORE= No netlink support
.endif
.endif
diff --git a/net/bird2/distinfo b/net/bird2/distinfo
index 3b3692fdba36..a689b2355f43 100644
--- a/net/bird2/distinfo
+++ b/net/bird2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1670848920
-SHA256 (bird-2.0.11.tar.gz) = 60a7b83b67b9d089d2a745a11fddd12461f631abc7b645b6c085adf90b3f55d6
-SIZE (bird-2.0.11.tar.gz) = 1301502
+TIMESTAMP = 1676386068
+SHA256 (bird-2.0.12.tar.gz) = 3ec462a237d06d1f4455d6ec00a42f0b1686061fc988e5c89a841d01dd753b53
+SIZE (bird-2.0.12.tar.gz) = 1307984
diff --git a/net/bird2/files/extra-patch-netlink b/net/bird2/files/extra-patch-netlink
deleted file mode 100644
index fd58ddaed2b3..000000000000
--- a/net/bird2/files/extra-patch-netlink
+++ /dev/null
@@ -1,31 +0,0 @@
-From d890c5cca7f6239ddd7ea605e45854658f50d39b Mon Sep 17 00:00:00 2001
-From: Alexander Chernikov <melifaro@FreeBSD.org>
-Date: Tue, 13 Sep 2022 12:08:58 +0000
-Subject: [PATCH 1/1] FreeBSD: add netlink support
-
-Netlink can be enabled by picking new sysconfig target:
-./configure --with-sysconfig=bsd-netlink
----
- sysdep/bsd-netlink/Makefile | 9 +++++++++
- sysdep/cf/bsd-netlink.h | 34 ++++++++++++++++++++++++++++++++++
- sysdep/cf/linux.h | 2 ++
- sysdep/linux/netlink.c | 7 ++++++-
- 4 files changed, 51 insertions(+), 1 deletion(-)
- create mode 100644 sysdep/bsd-netlink/Makefile
- create mode 100644 sysdep/cf/bsd-netlink.h
-
-diff --git sysdep/bsd-netlink/Makefile sysdep/bsd-netlink/Makefile
-new file mode 100644
-index 00000000..90b639a4
---- /dev/null
-+++ sysdep/bsd-netlink/Makefile
-@@ -0,0 +1,9 @@
-+src := $(s)../linux/netlink.c
-+obj := $(objdir)/sysdep/bsd-netlink/netlink.o
-+$(obj): $(src)
-+ $(E)echo CC -o $@ -c $<
-+ $(Q)$(CC) $(CFLAGS) -MMD -MP -o $@ -c $<
-+$(all-daemon)
-+$(conf-y-targets): $(s)../linux/netlink.Y
-+
-+tests_objs := $(tests_objs) $(obj)
diff --git a/net/bird2/files/patch-sysdep_bsd_sysio.h b/net/bird2/files/patch-sysdep_bsd_sysio.h
deleted file mode 100644
index 2991c873126e..000000000000
--- a/net/bird2/files/patch-sysdep_bsd_sysio.h
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git sysdep/bsd/sysio.h sysdep/bsd/sysio.h
-index f1887fb4..5167a5dd 100644
---- sysdep/bsd/sysio.h
-+++ sysdep/bsd/sysio.h
-@@ -48,11 +48,16 @@
- static inline int
- sk_setup_multicast4(sock *s)
- {
-- struct in_addr ifa = ip4_to_in4(s->iface->sysdep);
- u8 ttl = s->ttl;
- u8 n = 0;
-
- /* This defines where should we send _outgoing_ multicasts */
-+#ifdef __FreeBSD__
-+ struct ip_mreqn ifa = { .imr_ifindex = s->iface->index };
-+#else
-+ struct in_addr ifa = ip4_to_in4(s->iface->sysdep);
-+#endif
-+
- if (setsockopt(s->fd, IPPROTO_IP, IP_MULTICAST_IF, &ifa, sizeof(ifa)) < 0)
- ERR("IP_MULTICAST_IF");
-
-@@ -68,8 +73,11 @@ sk_setup_multicast4(sock *s)
- static inline int
- sk_join_group4(sock *s, ip_addr maddr)
- {
-+#ifdef __FreeBSD__
-+ struct ip_mreqn mr = { .imr_multiaddr = ipa_to_in4(maddr), .imr_ifindex = s->iface->index };
-+#else
- struct ip_mreq mr = INIT_MREQ4(maddr, s->iface);
--
-+#endif
- if (setsockopt(s->fd, IPPROTO_IP, IP_ADD_MEMBERSHIP, &mr, sizeof(mr)) < 0)
- ERR("IP_ADD_MEMBERSHIP");
-
-@@ -79,8 +87,11 @@ sk_join_group4(sock *s, ip_addr maddr)
- static inline int
- sk_leave_group4(sock *s, ip_addr maddr)
- {
-+#ifdef __FreeBSD__
-+ struct ip_mreqn mr = { .imr_multiaddr = ipa_to_in4(maddr), .imr_ifindex = s->iface->index };
-+#else
- struct ip_mreq mr = INIT_MREQ4(maddr, s->iface);
--
-+#endif
- if (setsockopt(s->fd, IPPROTO_IP, IP_DROP_MEMBERSHIP, &mr, sizeof(mr)) < 0)
- ERR("IP_ADD_MEMBERSHIP");
-
diff --git a/net/bird2/files/patch-sysdep_linux_netlink.c b/net/bird2/files/patch-sysdep_linux_netlink.c
deleted file mode 100644
index b84707c46be2..000000000000
--- a/net/bird2/files/patch-sysdep_linux_netlink.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- sysdep/linux/netlink.c.orig 2022-12-15 15:03:21 UTC
-+++ sysdep/linux/netlink.c
-@@ -27,15 +27,15 @@
- #include "lib/hash.h"
- #include "conf/conf.h"
-
-+#ifdef CONFIG_FREEBSD_NETLINK
-+#include <netlink/netlink.h>
-+#include <netlink/netlink_route.h>
-+#endif
- #ifdef CONFIG_LINUX_NETLINK
- #include <asm/types.h>
- #include <linux/if.h>
- #include <linux/netlink.h>
- #include <linux/rtnetlink.h>
--#endif
--#ifdef CONFIG_FREEBSD_NETLINK
--#include <netlink/netlink.h>
--#include <netlink/netlink_route.h>
- #endif
-
- #ifdef HAVE_MPLS_KERNEL