aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2023-07-09 19:55:07 +0000
committerJuraj Lutter <otis@FreeBSD.org>2023-07-09 20:12:17 +0000
commit76762720c39e9fefb19343d0fd07145819aed093 (patch)
tree65e1f06c1f2753d6eea49e1af797818912a620af
parent4483ac647438940c00061146cea5d01106c95f89 (diff)
downloadports-76762720c39e9fefb19343d0fd07145819aed093.tar.gz
ports-76762720c39e9fefb19343d0fd07145819aed093.zip
textproc/kibana7: Update to 7.17.11
-rw-r--r--textproc/kibana7/Makefile15
-rw-r--r--textproc/kibana7/distinfo10
-rw-r--r--textproc/kibana7/files/extra-node-re2-binding-gyp.patch13
3 files changed, 21 insertions, 17 deletions
diff --git a/textproc/kibana7/Makefile b/textproc/kibana7/Makefile
index e1606f4c2f0c..ff8e25d75561 100644
--- a/textproc/kibana7/Makefile
+++ b/textproc/kibana7/Makefile
@@ -1,7 +1,6 @@
PORTNAME= kibana
-PORTVERSION= 7.17.9
+PORTVERSION= 7.17.11
DISTVERSIONSUFFIX= -darwin-x86_64
-PORTREVISION= 1
CATEGORIES= textproc www
MASTER_SITES= https://artifacts.elastic.co/downloads/kibana/ \
http://artifacts.elastic.co/downloads/kibana/
@@ -14,9 +13,10 @@ WWW= https://www.elastic.co/products/kibana
LICENSE= APACHE20
-BUILD_DEPENDS= npm-node16>0:www/npm-node16
+BUILD_DEPENDS= npm-node16>=9.7.2:www/npm-node16
LIB_DEPENDS= libre2.so:devel/re2 \
libuv.so:devel/libuv
+RUN_DEPENDS= ${LOCALBASE}/bin/node:www/node16
USES= compiler:c++14-lang cpe nodejs:16,build,run python:build
CPE_VENDOR= elastic
@@ -29,6 +29,8 @@ USE_RC_SUBR= ${PORTNAME}
WWWDIR= ${PREFIX}/www/${PORTNAME}${PKGNAMESUFFIX}
+PORTSCOUT= limit:^7
+
SUB_FILES= pkg-deinstall
SUB_LIST+= PKGNAMESUFFIX=${PKGNAMESUFFIX} \
PORTNAME=${PORTNAME}
@@ -37,7 +39,7 @@ SUB_LIST+= PKGNAMESUFFIX=${PKGNAMESUFFIX} \
# Set node-nan version here
_NODE_NAN_VER= 2.17.0
# Set node-re version here
-_NODE_RE2_VER= 1.18.0
+_NODE_RE2_VER= 1.19.1
#######################################################################
_NODECMD= ${LOCALBASE}/bin/node --version
@@ -72,14 +74,15 @@ do-configure:
"! ( -name \.* -or -path *\/test\/* -or -name test )")
(cd ${_RE2DIR} && \
${SETENV} HOME=${WRKDIR} \
- ${LOCALBASE}/lib/node_modules/npm/bin/node-gyp-bin/node-gyp configure \
+ ${LOCALBASE}/lib/node_modules/npm/node_modules/.bin/node-gyp configure \
--python=${PYTHON_CMD} \
+ --nodedir=${LOCALBASE} \
--devdir=${_DEVDIR})
do-build:
(cd ${_RE2DIR} && \
${SETENV} HOME=${WRKDIR} \
- ${LOCALBASE}/lib/node_modules/npm/bin/node-gyp-bin/node-gyp build \
+ ${LOCALBASE}/lib/node_modules/npm/node_modules/.bin/node-gyp build \
--devdir=${_DEVDIR})
do-install:
diff --git a/textproc/kibana7/distinfo b/textproc/kibana7/distinfo
index c53c1be35620..17a0c99ff845 100644
--- a/textproc/kibana7/distinfo
+++ b/textproc/kibana7/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1675374196
-SHA256 (kibana-7.17.9-darwin-x86_64.tar.gz) = c34b2d3fc9c476eadd7600a998a12b182fba6cd94b7489ba5e8864389cbbf690
-SIZE (kibana-7.17.9-darwin-x86_64.tar.gz) = 311256712
+TIMESTAMP = 1688930582
+SHA256 (kibana-7.17.11-darwin-x86_64.tar.gz) = 6e00b5afad5dbde45c6a39e95141eab269e48420e7e9c156c80bcb6dba5bb194
+SIZE (kibana-7.17.11-darwin-x86_64.tar.gz) = 308454891
SHA256 (nodejs-nan-v2.17.0_GH0.tar.gz) = bcf5dfe59c26377b2096d903ecf6c2dbdae92528b1373a0565c40fe07537610d
SIZE (nodejs-nan-v2.17.0_GH0.tar.gz) = 179443
-SHA256 (uhop-node-re2-1.18.0_GH0.tar.gz) = 1a756518dc35ee07318e414338afaa8186c03d5929a609c51259d978359ee6b8
-SIZE (uhop-node-re2-1.18.0_GH0.tar.gz) = 51921
+SHA256 (uhop-node-re2-1.19.1_GH0.tar.gz) = 414a77a9690b074f88803b8d680684895ce470957b2b0af2008199df20c4a244
+SIZE (uhop-node-re2-1.19.1_GH0.tar.gz) = 47211
diff --git a/textproc/kibana7/files/extra-node-re2-binding-gyp.patch b/textproc/kibana7/files/extra-node-re2-binding-gyp.patch
index ebab5accfed0..47b14ac010d4 100644
--- a/textproc/kibana7/files/extra-node-re2-binding-gyp.patch
+++ b/textproc/kibana7/files/extra-node-re2-binding-gyp.patch
@@ -1,9 +1,10 @@
---- binding.gyp.orig 2021-05-10 04:34:55.000000000 +0200
-+++ binding.gyp 2021-07-05 19:22:23.670716000 +0200
-@@ -14,29 +14,6 @@
+--- binding.gyp.orig 2023-06-15 22:48:53.000000000 +0200
++++ binding.gyp 2023-07-09 21:24:09.709429000 +0200
+@@ -14,30 +14,6 @@
"lib/to_string.cc",
"lib/accessors.cc",
"lib/util.cc",
+- "vendor/re2/bitmap256.cc",
- "vendor/re2/bitstate.cc",
- "vendor/re2/compile.cc",
- "vendor/re2/dfa.cc",
@@ -29,8 +30,8 @@
- "vendor/util/strutil.cc"
],
"cflags": [
- "-std=c++14",
-@@ -45,7 +22,7 @@
+ "-std=c++2a",
+@@ -46,7 +22,7 @@
"-Wno-sign-compare",
"-Wno-unused-parameter",
"-Wno-missing-field-initializers",
@@ -39,7 +40,7 @@
"-O3",
"-g"
],
-@@ -54,7 +31,8 @@
+@@ -55,7 +31,8 @@
"NOMINMAX"
],
"include_dirs": [