aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorShane <FreeBSD@ShaneWare.Biz>2024-05-29 20:14:55 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-05-29 20:26:13 +0000
commit77a3d7607880649771f880868334f895ebb43650 (patch)
tree9b1a373a18b43722116f442445d8ab8b4f73b685
parent46d5b4b58122c5c54d41b7f288ea94febfe4f4a2 (diff)
downloadports-77a3d7607880649771f880868334f895ebb43650.tar.gz
ports-77a3d7607880649771f880868334f895ebb43650.zip
graphics/opensubdiv: update to 3.6.0
-rw-r--r--graphics/opensubdiv/Makefile10
-rw-r--r--graphics/opensubdiv/distinfo6
-rw-r--r--graphics/opensubdiv/files/patch-documentation_CMakeLists.txt11
-rw-r--r--graphics/opensubdiv/files/patch-opensubdiv_osd_tbbEvaluator.cpp28
-rw-r--r--graphics/opensubdiv/pkg-plist12
5 files changed, 18 insertions, 49 deletions
diff --git a/graphics/opensubdiv/Makefile b/graphics/opensubdiv/Makefile
index dd51cf960f13..ce5302b8356f 100644
--- a/graphics/opensubdiv/Makefile
+++ b/graphics/opensubdiv/Makefile
@@ -1,7 +1,6 @@
PORTNAME= opensubdiv
DISTVERSIONPREFIX= v
-DISTVERSION= 3_5_0
-PORTREVISION= 8
+DISTVERSION= 3_6_0
CATEGORIES?= graphics
MAINTAINER= FreeBSD@Shaneware.biz
@@ -13,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= glfw>3.0.0:graphics/glfw
-USES= cmake gl
+USES= cmake gl localbase
USE_GITHUB= yes
GH_ACCOUNT= PixarAnimationStudios
@@ -21,11 +20,10 @@ GH_PROJECT= OpenSubdiv
USE_GL= egl gl glu glew
USE_LDCONFIG= yes
-CMAKE_ON= NO_CLEW NO_CUDA NO_DX
+CMAKE_ON= NO_CLEW NO_CUDA NO_DX NO_METAL
OPTIONS_DEFINE= DOCS EXAMPLES OPENCL OPENMP PTEX TBB TEST TUTORIALS
OPTIONS_DEFAULT= TBB
-#OPTIONS_EXCLUDE= EXAMPLES
OPTIONS_SUB= yes
DOCS_CMAKE_BOOL_OFF= NO_DOC
@@ -34,8 +32,6 @@ DOCS_BUILD_DEPENDS= rst2html.py:textproc/py-docutils \
DOCS_USES= python:build
DOCS_PORTDOCS= *
-#EXAMPLES_BROKEN= ld: error: undefined symbol: glXGetCurrentContext
-#Examples cannot utilize the latest opencl headers
EXAMPLES_CMAKE_BOOL_OFF= NO_EXAMPLES
EXAMPLES_USES= xorg
EXAMPLES_USE= xorg=ice,sm,x11,xcursor,xext,xi,xinerama,xrandr,xxf86vm
diff --git a/graphics/opensubdiv/distinfo b/graphics/opensubdiv/distinfo
index 1fe4346efc27..7238a1c832e0 100644
--- a/graphics/opensubdiv/distinfo
+++ b/graphics/opensubdiv/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1665071456
-SHA256 (PixarAnimationStudios-OpenSubdiv-v3_5_0_GH0.tar.gz) = 8f5044f453b94162755131f77c08069004f25306fd6dc2192b6d49889efb8095
-SIZE (PixarAnimationStudios-OpenSubdiv-v3_5_0_GH0.tar.gz) = 40740801
+TIMESTAMP = 1702887114
+SHA256 (PixarAnimationStudios-OpenSubdiv-v3_6_0_GH0.tar.gz) = bebfd61ab6657a4f4ff27845fb66a167d00395783bfbd253254d87447ed1d879
+SIZE (PixarAnimationStudios-OpenSubdiv-v3_6_0_GH0.tar.gz) = 40746688
diff --git a/graphics/opensubdiv/files/patch-documentation_CMakeLists.txt b/graphics/opensubdiv/files/patch-documentation_CMakeLists.txt
deleted file mode 100644
index 422c75bcc330..000000000000
--- a/graphics/opensubdiv/files/patch-documentation_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- work/OpenSubdiv-3_2_0/documentation/CMakeLists.txt.orig 2017-07-07 01:16:15 UTC
-+++ documentation/CMakeLists.txt
-@@ -254,7 +254,7 @@ if (DOCUTILS_FOUND AND PYTHONINTERP_FOUN
- -E copy "${infile}" "${outfile}"
- )
-
-- add_custom_target( ${src} DEPENDS "${outfile}")
-+ #add_custom_target( ${src} DEPENDS "${outfile}")
-
- list(APPEND HTML_TARGETS ${src})
-
diff --git a/graphics/opensubdiv/files/patch-opensubdiv_osd_tbbEvaluator.cpp b/graphics/opensubdiv/files/patch-opensubdiv_osd_tbbEvaluator.cpp
deleted file mode 100644
index c8b44e2c7c65..000000000000
--- a/graphics/opensubdiv/files/patch-opensubdiv_osd_tbbEvaluator.cpp
+++ /dev/null
@@ -1,28 +0,0 @@
---- opensubdiv/osd/tbbEvaluator.cpp.orig 2021-12-17 16:59:23 UTC
-+++ opensubdiv/osd/tbbEvaluator.cpp
-@@ -25,7 +25,8 @@
- #include "../osd/tbbEvaluator.h"
- #include "../osd/tbbKernel.h"
-
--#include <tbb/task_scheduler_init.h>
-+#define TBB_PREVIEW_GLOBAL_CONTROL true
-+#include <tbb/global_control.h>
-
- namespace OpenSubdiv {
- namespace OPENSUBDIV_VERSION {
-@@ -215,10 +216,11 @@ TbbEvaluator::Synchronize(void *) {
- /* static */
- void
- TbbEvaluator::SetNumThreads(int numThreads) {
-- if (numThreads == -1) {
-- tbb::task_scheduler_init init;
-- } else {
-- tbb::task_scheduler_init init(numThreads);
-+ if (numThreads != -1) {
-+ tbb::global_control tbb_global_control(
-+ tbb::global_control::max_allowed_parallelism,
-+ numThreads
-+ );
- }
- }
-
diff --git a/graphics/opensubdiv/pkg-plist b/graphics/opensubdiv/pkg-plist
index 9fb8e05a77b1..35210bb87985 100644
--- a/graphics/opensubdiv/pkg-plist
+++ b/graphics/opensubdiv/pkg-plist
@@ -63,6 +63,8 @@ include/opensubdiv/osd/nonCopyable.h
@comment include/opensubdiv/osd/ompKernel.h
%%OPENCL%%include/opensubdiv/osd/opencl.h
include/opensubdiv/osd/opengl.h
+include/opensubdiv/osd/patchBasis.h
+include/opensubdiv/osd/patchBasisTypes.h
%%TBB%%include/opensubdiv/osd/tbbEvaluator.h
%%TBB%%include/opensubdiv/osd/tbbKernel.h
include/opensubdiv/osd/types.h
@@ -102,11 +104,21 @@ lib/libosdGPU.so.%%LIBVERS%%
%%EXAMPLES%%%%EXAMPLESDIR%%/glShareTopology
%%EXAMPLES%%%%EXAMPLESDIR%%/glStencilViewer
%%EXAMPLES%%%%EXAMPLESDIR%%/glViewer
+%%TEST%%tests/opensubdiv/bfr_evaluate
%%TEST%%tests/opensubdiv/far_perf
@comment %%TEST%%tests/opensubdiv/far_regression
@comment %%TEST%%tests/opensubdiv/hbr_baseline
@comment %%TEST%%tests/opensubdiv/hbr_regression
@comment %%TEST%%tests/opensubdiv/osd_regression
+%%TUTORIALS%%%%DATADIR%%/tutorials/bfr_tutorial_1_1
+%%TUTORIALS%%%%DATADIR%%/tutorials/bfr_tutorial_1_2
+%%TUTORIALS%%%%DATADIR%%/tutorials/bfr_tutorial_1_3
+%%TUTORIALS%%%%DATADIR%%/tutorials/bfr_tutorial_1_4
+%%TUTORIALS%%%%DATADIR%%/tutorials/bfr_tutorial_1_5
+%%TUTORIALS%%%%DATADIR%%/tutorials/bfr_tutorial_2_1
+%%TUTORIALS%%%%DATADIR%%/tutorials/bfr_tutorial_2_2
+%%TUTORIALS%%%%DATADIR%%/tutorials/bfr_tutorial_3_1
+%%TUTORIALS%%%%DATADIR%%/tutorials/bfr_tutorial_3_2
%%TUTORIALS%%%%DATADIR%%/tutorials/far_tutorial_1_1
%%TUTORIALS%%%%DATADIR%%/tutorials/far_tutorial_1_2
%%TUTORIALS%%%%DATADIR%%/tutorials/far_tutorial_2_1