aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-11-26 05:25:03 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-11-26 05:25:05 +0000
commit77ea6411e8deb12c116369e0c2e80040bd2617cc (patch)
treec74d6517cd54fa03a35c7e782b80ba1fff0a0ff7
parentad5fedf36832fd7e2447d8c4cb6b54128a2fcb20 (diff)
downloadports-77ea6411e8deb12c116369e0c2e80040bd2617cc.tar.gz
ports-77ea6411e8deb12c116369e0c2e80040bd2617cc.zip
devel/git-cinnabar: unbreak after 317ce5d4d408
helper/cinnabar-fast-import.c:525:5: error: redefinition of 'write_object_file' int write_object_file(const void *buf, unsigned long len, const char *type, ^ ./object-store.h:229:19: note: previous definition is here static inline int write_object_file(const void *buf, unsigned long len, ^
-rw-r--r--devel/git-cinnabar/Makefile1
-rw-r--r--devel/git-cinnabar/files/patch-git-2.3366
2 files changed, 1 insertions, 66 deletions
diff --git a/devel/git-cinnabar/Makefile b/devel/git-cinnabar/Makefile
index 9351245fefc4..e61367220f59 100644
--- a/devel/git-cinnabar/Makefile
+++ b/devel/git-cinnabar/Makefile
@@ -1,5 +1,6 @@
PORTNAME= git-cinnabar
DISTVERSION= 0.5.8
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= jbeich@FreeBSD.org
diff --git a/devel/git-cinnabar/files/patch-git-2.33 b/devel/git-cinnabar/files/patch-git-2.33
deleted file mode 100644
index 6ee6e1162de0..000000000000
--- a/devel/git-cinnabar/files/patch-git-2.33
+++ /dev/null
@@ -1,66 +0,0 @@
-Revert https://github.com/glandium/git-cinnabar/commit/6ced6a84edc1
-until devel/git tracks 2.34.0 or later
-
---- helper/GIT-VERSION.mk.orig 2021-11-19 21:23:13 UTC
-+++ helper/GIT-VERSION.mk
-@@ -1,2 +1,2 @@
--GIT_VERSION ?= v2.34.0
-+GIT_VERSION ?= v2.33.1
- WINDOWS_GIT_VERSION ?= $(GIT_VERSION).windows.1
---- helper/cinnabar-fast-import.c.orig 2021-11-19 21:23:13 UTC
-+++ helper/cinnabar-fast-import.c
-@@ -522,8 +522,8 @@ static void do_set(struct string_list *args)
- }
- }
-
--int write_object_file_flags(const void *buf, unsigned long len, const char *type,
-- struct object_id *oid, unsigned flags)
-+int write_object_file(const void *buf, unsigned long len, const char *type,
-+ struct object_id *oid)
- {
- struct strbuf data;
- enum object_type t;
---- helper/hg-connect-http.c.orig 2021-11-19 21:23:13 UTC
-+++ helper/hg-connect-http.c
-@@ -408,7 +408,7 @@ struct hg_connection *hg_connect_http(const char *url,
- struct hg_connection *conn = xmalloc(sizeof(*conn));
- struct strbuf caps = STRBUF_INIT;
- struct writer writer;
-- string_list_init_dup(&conn->capabilities);
-+ string_list_init(&conn->capabilities, 1);
-
- conn->http.url = xstrdup(url);
- conn->http.initial_request = 1;
---- helper/hg-connect-stdio.c.orig 2021-11-19 21:23:13 UTC
-+++ helper/hg-connect-stdio.c
-@@ -206,7 +206,7 @@ struct hg_connection *hg_connect_stdio(const char *url
- struct strbuf buf = STRBUF_INIT;
- struct hg_connection *conn = xmalloc(sizeof(*conn));
- struct child_process *proc = &conn->stdio.proc;
-- string_list_init_dup(&conn->capabilities);
-+ string_list_init(&conn->capabilities, 1);
-
- protocol = parse_connect_url(url, &hostandport, &path);
-
---- helper/object-file.c.patch.orig 2021-11-19 21:23:13 UTC
-+++ helper/object-file.c.patch
-@@ -1,13 +1,13 @@
- diff --git a/object-file.c b/object-file.c
--index c3d866a287..904149ce90 100644
-+index 188de57634..7b06e56727 100644
- --- a/object-file.c
- +++ b/object-file.c
--@@ -1954,7 +1954,7 @@ static int freshen_packed_object(const struct object_id *oid)
-+@@ -1868,7 +1868,7 @@ static int freshen_packed_object(const struct object_id *oid)
- return 1;
- }
-
---int write_object_file_flags(const void *buf, unsigned long len,
--+int real_write_object_file_flags(const void *buf, unsigned long len,
-- const char *type, struct object_id *oid,
-- unsigned flags)
-+-int write_object_file(const void *buf, unsigned long len, const char *type,
-++int real_write_object_file(const void *buf, unsigned long len, const char *type,
-+ struct object_id *oid)
- {
-+ char hdr[MAX_HEADER_LEN];