aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-12-10 19:39:11 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-12-11 12:46:37 +0000
commit780726c8be59e7fca07a04e904cc4c90cc7fba43 (patch)
tree2cd53fbe3a2bd865ba26ccad9a4ba299d46f0001
parent7cbf21ebf86d3aed14016c1e7fb3060d302352fe (diff)
downloadports-780726c8be59e7fca07a04e904cc4c90cc7fba43.tar.gz
ports-780726c8be59e7fca07a04e904cc4c90cc7fba43.zip
mail/fetchmail: update 6.4.25, add WOLFSSL support
WOLFSSL is a GPLv2+ licensed SSL library with OpenSSL compatibility layer. This is to permit shipping fetchmail under a clean GPLv2+ license with OpenSSL 1.1.1. (cherry picked from commit a1be1173a389c69879a2747a584728bba3a5d722)
-rw-r--r--mail/fetchmail/Makefile28
-rw-r--r--mail/fetchmail/distinfo6
-rw-r--r--mail/fetchmailconf/Makefile1
3 files changed, 22 insertions, 13 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 66474be62251..b4c4dcceb64f 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -1,7 +1,7 @@
# Created by: Ville Eerola <ve@sci.fi>
PORTNAME?= fetchmail
-DISTVERSION= 6.4.24
+DISTVERSION= 6.4.25
PORTREVISION?= 0
CATEGORIES= mail
# The next line is inherited by the fetchmailconf dependent port,
@@ -14,9 +14,9 @@ COMMENT?= Batch mail retrieval utility for IMAP/POP3/ETRN/ODMR
LICENSE= GPLv2+
.if empty(MASTERDIR)
-USES= cpe gmake ssl tar:xz
+USES= cpe gmake tar:xz
IGNORE_SSL= libressl libressl-devel
-IGNORE_SSL_REASON=incompatible license/no GPLv2 clause 2b exception for LibreSSL
+IGNORE_SSL_REASON= incompatible license/no GPLv2 clause 2b exception for LibreSSL
# The Free Software Foundation asserts that a GPL v2 clause 2b exception is
# required even for dynamically linked binaries. See
# https://www.gnu.org/licenses/gpl-faq.en.html#GPLStaticVsDynamic
@@ -31,7 +31,6 @@ CONFIGURE_ARGS= --enable-fallback=no \
--enable-opie \
--enable-RPA \
--enable-SDPS \
- --with-ssl=${OPENSSLBASE} \
--without-hesiod \
PYTHON=:
@@ -44,11 +43,17 @@ SUB_FILES= pkg-message
USERS= ${PORTNAME}
GROUPS= ${USERS}
+PORTDOCS= FAQ FEATURES NEWS NOTES OLDNEWS README README.SSL \
+ README.SSL-SERVER design-notes.html esrs-design-notes.html \
+ fetchmail-FAQ.html fetchmail-features.html todo.html
+
OPTIONS_DEFINE= CA_BUNDLE DOCS NLS
-OPTIONS_DEFAULT= CA_BUNDLE GSSAPI_BASE
-OPTIONS_SINGLE= GSSAPI
+OPTIONS_DEFAULT= CA_BUNDLE GSSAPI_BASE OPENSSL
+OPTIONS_SINGLE= GSSAPI TLS
OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
-OPTIONS_SUB= yes
+OPTIONS_SINGLE_TLS= OPENSSL WOLFSSL
+
+OPTIONS_SUB= yes
CA_BUNDLE_DESC= Install CA bundle for OpenSSL
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
@@ -67,9 +72,12 @@ GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-PORTDOCS= FAQ FEATURES NEWS NOTES OLDNEWS README README.SSL \
- README.SSL-SERVER design-notes.html esrs-design-notes.html \
- fetchmail-FAQ.html fetchmail-features.html todo.html
+OPENSSL_CONFIGURE_WITH= ssl=${OPENSSLBASE}
+
+WOLFSSL_LIB_DEPENDS= libwolfssl.so:security/wolfssl
+WOLFSSL_USES_OFF= ssl
+WOLFSSL_CONFIGURE_ON= WOLFSSL_TRUST_FILE=${LOCALBASE}/share/certs/ca-root-nss.crt
+WOLFSSL_CONFIGURE_WITH= wolfssl=${LOCALBASE}
post-patch:
.if !exists(/usr/lib/libcom_err.so)
diff --git a/mail/fetchmail/distinfo b/mail/fetchmail/distinfo
index c2d2a1175c8c..ecbfe5e751fb 100644
--- a/mail/fetchmail/distinfo
+++ b/mail/fetchmail/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637401885
-SHA256 (fetchmail-6.4.24.tar.xz) = 9c961df25cd922f539218b0b56a77e7a47778e49ed907edaa5b4941ad3b253cf
-SIZE (fetchmail-6.4.24.tar.xz) = 1331764
+TIMESTAMP = 1639176375
+SHA256 (fetchmail-6.4.25.tar.xz) = 7ebefbe89172fd59f0fd8317d8743a8436f375ccdcab3900e4c3ec06a8fbf27f
+SIZE (fetchmail-6.4.25.tar.xz) = 1343360
diff --git a/mail/fetchmailconf/Makefile b/mail/fetchmailconf/Makefile
index 63599abe7b3f..442a37e5eefe 100644
--- a/mail/fetchmailconf/Makefile
+++ b/mail/fetchmailconf/Makefile
@@ -20,6 +20,7 @@ USES= python shebangfix tar:xz
USE_PYTHON= py3kplist
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= PKG_CONFIG=:
ALL_TARGET= fetchmailconf
INSTALL_TARGET= install-data-am install-nodist_binSCRIPTS install-man