aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-11-12 04:48:09 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-11-12 04:49:08 +0000
commit788b0b575cd6b1b9bf60b281653c40f4989eee3a (patch)
treeee0fe7f13c9003851c629a183fe9bf2661ceb9b6
parentc4a6ac08f5623e023e872eca1d96ad88973ebe9c (diff)
downloadports-788b0b575cd6b1b9bf60b281653c40f4989eee3a.tar.gz
ports-788b0b575cd6b1b9bf60b281653c40f4989eee3a.zip
math/py-scikit-quant: New port: Aggregator package for interoperability for quantum computing software
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-scikit-quant/Makefile26
-rw-r--r--misc/py-scikit-quant/distinfo3
-rw-r--r--misc/py-scikit-quant/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 59d8b25c696d..cdd31ebd6f70 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -470,6 +470,7 @@
SUBDIR += py-pytorch-lightning
SUBDIR += py-qiskit-machine-learning
SUBDIR += py-scikit-fusion
+ SUBDIR += py-scikit-quant
SUBDIR += py-serverfiles
SUBDIR += py-shap2
SUBDIR += py-shell-gpt
diff --git a/misc/py-scikit-quant/Makefile b/misc/py-scikit-quant/Makefile
new file mode 100644
index 000000000000..6ad1c17923af
--- /dev/null
+++ b/misc/py-scikit-quant/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= scikit-quant
+DISTVERSION= 0.8.2
+CATEGORIES= misc python # quantum-computing
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Aggregator package for interoperability for quantum computing software
+WWW= http://scikit-quant.org
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Py-BOBYQA>=1.2:math/py-Py-BOBYQA@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}SQCommon>0:misc/py-SQCommon@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}SQImFil>0:misc/py-SQImFil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}SQNomad>0:math/py-SQNomad@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}SQSnobFit>0:misc/py-SQSnobFit@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist pytest # several tests fail, see https://github.com/scikit-quant/scikit-quant/issues/25
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-scikit-quant/distinfo b/misc/py-scikit-quant/distinfo
new file mode 100644
index 000000000000..2ed640aacb86
--- /dev/null
+++ b/misc/py-scikit-quant/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1699734206
+SHA256 (scikit-quant-0.8.2.tar.gz) = 53bbcc4d4a4351dd3965eddd35143d4ef15518f42a6db4b6550cb836dfa3747a
+SIZE (scikit-quant-0.8.2.tar.gz) = 20974
diff --git a/misc/py-scikit-quant/pkg-descr b/misc/py-scikit-quant/pkg-descr
new file mode 100644
index 000000000000..35f57a7ce789
--- /dev/null
+++ b/misc/py-scikit-quant/pkg-descr
@@ -0,0 +1,4 @@
+scikit-quant is an aggregator package to improve interoperability between
+quantum computing software packages. Our first focus in on classical optimizers,
+making the state-of-the art from the Applied Math community available in Python
+for use in quantum computing.