aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2024-01-27 10:46:17 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2024-01-27 10:50:42 +0000
commit788bd5f72d97fc75aa68e99f80c19ae07bc22f95 (patch)
treedaa18b45d206572e5df7714590be5b91672a647c
parente44c9efcca8e50a586976ce3b63032ed63208a55 (diff)
downloadports-788bd5f72d97fc75aa68e99f80c19ae07bc22f95.tar.gz
ports-788bd5f72d97fc75aa68e99f80c19ae07bc22f95.zip
japanese/anthy: Fix runtime error of anthy.el with emacs-29.1
PR: 276493 Submitted by: Akira Sasaki <mah-chan@eagle.ocn.ne.jp>
-rw-r--r--japanese/anthy/Makefile2
-rw-r--r--japanese/anthy/files/patch-src-util_anthy.el18
2 files changed, 19 insertions, 1 deletions
diff --git a/japanese/anthy/Makefile b/japanese/anthy/Makefile
index f80dd0c3b327..8a66dc494b8e 100644
--- a/japanese/anthy/Makefile
+++ b/japanese/anthy/Makefile
@@ -1,6 +1,6 @@
PORTNAME= anthy
PORTVERSION= 0.4
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= japanese
MASTER_SITES= DEBIAN
diff --git a/japanese/anthy/files/patch-src-util_anthy.el b/japanese/anthy/files/patch-src-util_anthy.el
index e8b6d1da7a6d..db8206b44b7f 100644
--- a/japanese/anthy/files/patch-src-util_anthy.el
+++ b/japanese/anthy/files/patch-src-util_anthy.el
@@ -18,3 +18,21 @@
(if anthy-xemacs
(if (coding-system-p (find-coding-system 'euc-japan))
(set-process-coding-system proc 'euc-japan 'euc-japan))
+@@ -864,7 +864,7 @@
+ ;; leim の activate
+ ;;
+ (defun anthy-leim-activate (&optional name)
+- (setq inactivate-current-input-method-function 'anthy-leim-inactivate)
++ (setq deactivate-current-input-method-function 'anthy-leim-inactivate)
+ (setq anthy-leim-active-p t)
+ (anthy-update-mode)
+ (when (eq (selected-window) (minibuffer-window))
+@@ -874,7 +874,7 @@
+ ;; emacsのバグ避けらしいです
+ ;;
+ (defun anthy-leim-exit-from-minibuffer ()
+- (inactivate-input-method)
++ (deactivate-input-method)
+ (when (<= (minibuffer-depth) 1)
+ (remove-hook 'minibuffer-exit-hook 'anthy-leim-exit-from-minibuffer)))
+