aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2021-10-17 03:11:29 +0000
committerWen Heping <wen@FreeBSD.org>2021-10-17 03:11:29 +0000
commit78d4278cd212919fc5d1455ebb4b6f9726698d19 (patch)
tree789ea7288cb391ed53bd6579ab36ff5db88ec0e6
parent924de742fc23ab02e5f95de8515c0a5be495c0ab (diff)
downloadports-78d4278cd212919fc5d1455ebb4b6f9726698d19.tar.gz
ports-78d4278cd212919fc5d1455ebb4b6f9726698d19.zip
databases/zodb: Add new port
ZODB provides an object-oriented database for Python that provides a high-degree of transparency. ZODB runs on Python 2.7 or Python 3.4 and above. It also runs on PyPy. *no separate language for database operations *very little impact on your code to make objects persistent *no database mapper that partially hides the database. *Using an object-relational mapping is not like using an object-oriented database. *almost no seam between code and database. WWW: https://github.com/zopefoundation/zodb
-rw-r--r--databases/Makefile1
-rw-r--r--databases/zodb/Makefile26
-rw-r--r--databases/zodb/distinfo3
-rw-r--r--databases/zodb/pkg-descr12
4 files changed, 42 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 9ba310b08adf..969cc96719d1 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -1051,5 +1051,6 @@
SUBDIR += xtrabackup
SUBDIR += xtrabackup8
SUBDIR += zabbix3-libzbxpgsql
+ SUBDIR += zodb
.include <bsd.port.subdir.mk>
diff --git a/databases/zodb/Makefile b/databases/zodb/Makefile
new file mode 100644
index 000000000000..8a3f3889ff78
--- /dev/null
+++ b/databases/zodb/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= zodb
+PORTVERSION= 5.6.0
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ZODB-${PORTVERSION}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Python object-oriented database
+
+LICENSE= ZPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}persistent>=4.4.0:devel/py-persistent@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}BTrees>=4.2.0:devel/py-BTrees@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zconfig>0:devel/py-zconfig@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}transaction>=2.4:devel/py-transaction@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zclockfile>=0:devel/py-zclockfile@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:devel/py-zope.interface@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zodbpickle>=1.0.1:databases/py-zodbpickle@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/databases/zodb/distinfo b/databases/zodb/distinfo
new file mode 100644
index 000000000000..65dd4cae697d
--- /dev/null
+++ b/databases/zodb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634437077
+SHA256 (ZODB-5.6.0.tar.gz) = 4654fb543393533291cfbf8adfb4ea2658ff385871d4b926d725508142cb07fe
+SIZE (ZODB-5.6.0.tar.gz) = 516570
diff --git a/databases/zodb/pkg-descr b/databases/zodb/pkg-descr
new file mode 100644
index 000000000000..2d81aeca2bfe
--- /dev/null
+++ b/databases/zodb/pkg-descr
@@ -0,0 +1,12 @@
+ZODB provides an object-oriented database for Python that provides
+a high-degree of transparency. ZODB runs on Python 2.7 or Python 3.4
+ and above. It also runs on PyPy.
+
+*no separate language for database operations
+*very little impact on your code to make objects persistent
+*no database mapper that partially hides the database.
+*Using an object-relational mapping is not like using an object-oriented
+database.
+*almost no seam between code and database.
+
+WWW: https://github.com/zopefoundation/zodb