aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-10-14 11:51:12 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-10-14 11:51:12 +0000
commit799d4cc2cfd1c343f486afbde5cc735ec206de2e (patch)
tree458c38d9907692f1e966f97af84d36e7a942d4c2
parent3b237ddba92c02a899db2038123dd51db549fdd2 (diff)
downloadports-799d4cc2cfd1c343f486afbde5cc735ec206de2e.tar.gz
ports-799d4cc2cfd1c343f486afbde5cc735ec206de2e.zip
biology/py-deeptools: User-friendly tools for exploring deep-sequencing data
deepTools contains useful modules to process the mapped reads data for multiple quality checks, creating normalized coverage files in standard bedGraph and bigWig file formats, that allow comparison between different files (for example, treatment and control). Finally, using such normalized and standardized files, deepTools can create many publication-ready visualizations to identify enrichments and for functional annotations of the genome.
-rw-r--r--biology/Makefile1
-rw-r--r--biology/py-deeptools/Makefile26
-rw-r--r--biology/py-deeptools/distinfo3
-rw-r--r--biology/py-deeptools/pkg-descr9
4 files changed, 39 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index a49bdebebeef..c4fd2890bcf3 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -144,6 +144,7 @@
SUBDIR += py-bx-python
SUBDIR += py-crossmap
SUBDIR += py-cutadapt
+ SUBDIR += py-deeptools
SUBDIR += py-deeptoolsintervals
SUBDIR += py-dnaio
SUBDIR += py-ete3
diff --git a/biology/py-deeptools/Makefile b/biology/py-deeptools/Makefile
new file mode 100644
index 000000000000..fb7dd40ad021
--- /dev/null
+++ b/biology/py-deeptools/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= deepTools
+DISTVERSION= 3.5.1
+CATEGORIES= biology python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= User-friendly tools for exploring deep-sequencing data
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.17.0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=3.3.0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pysam>=0.14.0:biology/py-pysam@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}py2bit>=0.3.0:biology/py-py2bit@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpydoc>=0.5:textproc/py-numpydoc@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyBigWig>=0.3.18:biology/py-pybigwig@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}plotly>=4.9:graphics/py-plotly@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}deeptoolsintervals>=0.1.8:biology/py-deeptoolsintervals@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/biology/py-deeptools/distinfo b/biology/py-deeptools/distinfo
new file mode 100644
index 000000000000..8e524e070d7b
--- /dev/null
+++ b/biology/py-deeptools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1617285775
+SHA256 (deepTools-3.5.1.tar.gz) = 62eea132513afa5f6bb51387e5866a5c3a26613aeb7e8c9600c38becf2ecb716
+SIZE (deepTools-3.5.1.tar.gz) = 199732
diff --git a/biology/py-deeptools/pkg-descr b/biology/py-deeptools/pkg-descr
new file mode 100644
index 000000000000..35d810a014b3
--- /dev/null
+++ b/biology/py-deeptools/pkg-descr
@@ -0,0 +1,9 @@
+deepTools contains useful modules to process the mapped reads data for
+multiple quality checks, creating normalized coverage files in standard
+bedGraph and bigWig file formats, that allow comparison between
+different files (for example, treatment and control). Finally, using
+such normalized and standardized files, deepTools can create many
+publication-ready visualizations to identify enrichments and for
+functional annotations of the genome.
+
+WWW: https://github.com/deeptools/deepTools