aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-18 19:36:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-18 19:37:10 +0000
commit79be00646bc533128e0a0c52bf73ed5f049773dc (patch)
tree7845c30cbdb9578bedd36b6dae46b5675d1d99c9
parent7be8b69ce034277c038e7390748307ab9baed3b6 (diff)
downloadports-79be00646bc533128e0a0c52bf73ed5f049773dc.tar.gz
ports-79be00646bc533128e0a0c52bf73ed5f049773dc.zip
science/axom: Add dependencies
-rw-r--r--science/axom/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/science/axom/Makefile b/science/axom/Makefile
index d9cf5d84fd95..e737199bed11 100644
--- a/science/axom/Makefile
+++ b/science/axom/Makefile
@@ -1,6 +1,7 @@
PORTNAME= axom
DISTVERSIONPREFIX= v
DISTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -9,7 +10,10 @@ COMMENT= Infrastructure for development of multi-physics applications and tools
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/../LICENSE
-LIB_DEPENDS= libconduit.so:science/conduit
+LIB_DEPENDS= libconduit.so:science/conduit \
+ libhdf5.so:science/hdf5 \
+ libsiloh5.so:science/silo \
+ libsz.so:science/szip
RUN_DEPENDS= sparsehash>0:devel/sparsehash
USES= cmake compiler:c++11-lang
@@ -22,7 +26,8 @@ GH_TUPLE= LLNL:axom_data:517e53e:axom_data/../data \
CMAKE_OFF= AXOM_ENABLE_DOCS AXOM_ENABLE_EXAMPLES AXOM_ENABLE_TESTS FREEBSD_ENABLE_EXAMPLES
CMAKE_ON= BUILD_SHARED_LIBS
-CMAKE_ARGS= -DCONDUIT_DIR=${LOCALBASE}
+CMAKE_ARGS= -DCONDUIT_DIR=${LOCALBASE} \
+ -DHDF5_DIR=${LOCALBASE}
LDFLAGS+= -lexecinfo