aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2023-05-22 15:41:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2023-05-22 18:27:10 +0000
commit79e392c15d25a7fac189d22fe2d0c59585306f4f (patch)
tree160ea7894a4287e267d261806e4cf6bd4a92c5e8
parent092787dffe45ea6ee1c5ea3b8cede34eea142992 (diff)
downloadports-79e392c15d25a7fac189d22fe2d0c59585306f4f.tar.gz
ports-79e392c15d25a7fac189d22fe2d0c59585306f4f.zip
games/instead: enable harfbuzz support, fix lua(jit) deps
- Enable harfbuzz support which is now available in SDL2_ttf (disabled by default according to upstream setting) [1] - Switch luajit dependency to USES=luajit (it also should now work on powerpc, so a related hack is no longer needed) - Fix dependency on lua - Remove no longer needed CMake argument PR: 271545 [1] Reported by: jbeich [1]
-rw-r--r--games/instead/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/games/instead/Makefile b/games/instead/Makefile
index c4647f6e83af..b1fdc3c8e1ad 100644
--- a/games/instead/Makefile
+++ b/games/instead/Makefile
@@ -1,6 +1,6 @@
PORTNAME= instead
PORTVERSION= 3.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -12,16 +12,15 @@ WWW= https://instead.syscall.ru/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake compiler:c++11-lang iconv lua:51 pkgconfig sdl
+USES= cmake compiler:c++11-lang iconv pkgconfig sdl
USE_SDL= sdl2 image2 ttf2 mixer2
-CMAKE_ARGS= -DMANDIR=share/man
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= *
PORTDATA= *
-OPTIONS_DEFINE= LUAJIT DOCS # HARFBUZZ # requires unreleased version of sdl2_ttf
+OPTIONS_DEFINE= LUAJIT DOCS HARFBUZZ
OPTIONS_DEFAULT= LUAJIT GTK3
OPTIONS_RADIO= GTK_VERSION
OPTIONS_RADIO_GTK_VERSION= GTK2 GTK3
@@ -38,16 +37,10 @@ GTK2_CMAKE_BOOL= WITH_GTK2
GTK3_USES= gnome
GTK3_USE= GNOME=gtk30
GTK3_CMAKE_BOOL= WITH_GTK3
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
-LUAJIT_USE_OFF= lua:51
+LUAJIT_USES= luajit
+LUAJIT_USES_OFF= lua:51
LUAJIT_CMAKE_BOOL= WITH_LUAJIT
HARFBUZZ_CMAKE_BOOL= WITH_HARFBUZZ
HARFBUZZ_LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
-.include <bsd.port.options.mk>
-
-.if ${ARCH:Mpowerpc64*}
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
-.endif
-
.include <bsd.port.mk>