aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Timofeev <timp87@gmail.com>2023-10-19 20:45:54 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-10-23 01:51:28 +0000
commit79f74ed60e1aa1a08f983af1f72204d7c8929d8a (patch)
tree7dbbcba9ae0643f031ea05ddfc55344a4a44f2e0
parente79009308a180218105f66d31a6dd9e5b755db73 (diff)
downloadports-79f74ed60e1aa1a08f983af1f72204d7c8929d8a.tar.gz
ports-79f74ed60e1aa1a08f983af1f72204d7c8929d8a.zip
games/jaggedalliance2: unbreak i386 build on fbsd 14+
- unbreak i386 build on fbsd 14+ - remove unnecessary lua version hardcode - bump port revision PR: 274601 MFH: 2023Q4
-rw-r--r--games/jaggedalliance2/Makefile17
-rw-r--r--games/jaggedalliance2/files/patch-dependencies_lib-lua_CMakeLists.txt11
2 files changed, 4 insertions, 24 deletions
diff --git a/games/jaggedalliance2/Makefile b/games/jaggedalliance2/Makefile
index 2900c48ee3c2..c0d021a4616f 100644
--- a/games/jaggedalliance2/Makefile
+++ b/games/jaggedalliance2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= ja2
DISTVERSIONPREFIX= v
DISTVERSION= 0.20.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MAINTAINER= timp87@gmail.com
@@ -25,7 +25,7 @@ BUILD_DEPENDS= string_theory>=3.1:devel/string_theory \
miniaudio>=0.11.9:audio/miniaudio
LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
-USES= cargo cmake compiler:c++17-lang pkgconfig sdl xorg gl lua:53
+USES= cargo cmake compiler:c++17-lang pkgconfig sdl xorg gl lua:53+
USE_GITHUB= yes
GH_ACCOUNT= ja2-stracciatella
GH_PROJECT= ja2-stracciatella
@@ -176,17 +176,8 @@ post-install:
.include <bsd.port.pre.mk>
-# Compilation with clang's broken in 14-CURRENT
-.if ${OSVERSION} >= 1400000
-# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=236344
-# Copy-pasted gcc-c++11-lib from Mk/Uses/compiler.mk
-USE_GCC= yes
-CHOSEN_COMPILER_TYPE= gcc
-CXXFLAGS+= -nostdinc++ -isystem /usr/include/c++/v1
-LDFLAGS+= -L${WRKDIR}
-_USES_configure+= 200:gcc-libc++-configure
-gcc-libc++-configure:
- @${LN} -fs /usr/lib/libc++.so ${WRKDIR}/libstdc++.so
+.if ${OSVERSION} >= 1400000 && ${ARCH} == "i386"
+CXXFLAGS+= -Wno-error=enum-constexpr-conversion
.endif
.include <bsd.port.post.mk>
diff --git a/games/jaggedalliance2/files/patch-dependencies_lib-lua_CMakeLists.txt b/games/jaggedalliance2/files/patch-dependencies_lib-lua_CMakeLists.txt
deleted file mode 100644
index 6f12a6ce12ba..000000000000
--- a/games/jaggedalliance2/files/patch-dependencies_lib-lua_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- dependencies/lib-lua/CMakeLists.txt.orig 2023-01-25 17:13:43 UTC
-+++ dependencies/lib-lua/CMakeLists.txt
-@@ -3,7 +3,7 @@
- option(LOCAL_LUA_LIB "Download and build Lua instead of searching the system" ON)
- if (NOT LOCAL_LUA_LIB)
- message(STATUS "Using system Lua")
-- find_package(Lua "5.3" REQUIRED)
-+ find_package(Lua "5.3" REQUIRED EXACT)
- if (NOT LUA_FOUND)
- message(FATAL_ERROR "Lua 5.3 not found")
- endif()