aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2024-02-01 02:41:31 +0000
committerCharlie Li <vishwin@FreeBSD.org>2024-02-01 02:41:31 +0000
commit7a11a9f2280f0e1639e869af59c436e255a7fa74 (patch)
tree04a4bc03295c0477b1d34c8b64bfa100023effd3
parent35f1f084f47947146aab3904398c6079ef10444b (diff)
downloadports-7a11a9f2280f0e1639e869af59c436e255a7fa74.tar.gz
ports-7a11a9f2280f0e1639e869af59c436e255a7fa74.zip
security/archlinux-keyring: limit to Python 3.10 and later
libkeyringctl/trust.py includes Structural Pattern Matching (PEP-636) introduced in Python 3.10. https://gitlab.archlinux.org/archlinux/archlinux-keyring/-/merge_requests/267
-rw-r--r--security/archlinux-keyring/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/archlinux-keyring/Makefile b/security/archlinux-keyring/Makefile
index 420d91a93b4c..8ad4b12c1a7b 100644
--- a/security/archlinux-keyring/Makefile
+++ b/security/archlinux-keyring/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= sq:security/sequoia-sq \
RUN_DEPENDS= bash:shells/bash \
pacman-key:sysutils/pacman@archlinux
-USES= gmake pkgconfig python shebangfix trigger
+USES= gmake pkgconfig python:3.10+ shebangfix trigger
SHEBANG_FILES= keyringctl wkd_sync
BINARY_ALIAS= install=ginstall