aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-26 17:00:44 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-26 17:43:55 +0000
commit7a191018020d0191de863bf7f36db9d3bfdac53b (patch)
tree88ae9b1b281c46ddbb912a252930ef83a140d099
parentc0f1282a1cfc26c5d3dc6a2cbacf8f6aadb2c1c2 (diff)
downloadports-7a191018020d0191de863bf7f36db9d3bfdac53b.tar.gz
ports-7a191018020d0191de863bf7f36db9d3bfdac53b.zip
graphics/rlottie: New port: Platform independent standalone library that plays Lottie Animation
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/rlottie/Makefile25
-rw-r--r--graphics/rlottie/distinfo3
-rw-r--r--graphics/rlottie/pkg-descr8
-rw-r--r--graphics/rlottie/pkg-plist13
5 files changed, 50 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 11943f963b00..0c5d8b4021c5 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -957,6 +957,7 @@
SUBDIR += rigsofrods-caelum
SUBDIR += rigsofrods-pagedgeometry
SUBDIR += ristretto
+ SUBDIR += rlottie
SUBDIR += ruby-gd
SUBDIR += rubygem-cairo
SUBDIR += rubygem-captcha
diff --git a/graphics/rlottie/Makefile b/graphics/rlottie/Makefile
new file mode 100644
index 000000000000..1c576d2899f1
--- /dev/null
+++ b/graphics/rlottie/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= rlottie
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2-49
+DISTVERSIONSUFFIX= -g327fb7d
+CATEGORIES= graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Platform independent standalone library that plays Lottie Animation
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/licenses/COPYING.MIT
+
+USES= cmake:testing compiler:c++14-lang
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= Samsung
+
+CMAKE_ARGS= -DLIB_INSTALL_DIR=${PREFIX}/lib
+CMAKE_TESTING_ON= LOTTIE_TEST
+
+post-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/example/lottie2gif ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/rlottie/distinfo b/graphics/rlottie/distinfo
new file mode 100644
index 000000000000..99d07b3beeb2
--- /dev/null
+++ b/graphics/rlottie/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632674667
+SHA256 (Samsung-rlottie-v0.2-49-g327fb7d_GH0.tar.gz) = aa4df4de7d987077535c8d66003db02a8fdd0a0892c574ee612b513e15a061a2
+SIZE (Samsung-rlottie-v0.2-49-g327fb7d_GH0.tar.gz) = 4046773
diff --git a/graphics/rlottie/pkg-descr b/graphics/rlottie/pkg-descr
new file mode 100644
index 000000000000..9675420fc27a
--- /dev/null
+++ b/graphics/rlottie/pkg-descr
@@ -0,0 +1,8 @@
+rlottie is a platform independent standalone c++ library for rendering vector
+based animations and art in realtime.
+
+Lottie loads and renders animations and vectors exported in the bodymovin JSON
+format. Bodymovin JSON can be created and exported from After Effects with
+bodymovin, Sketch with Lottie Sketch Export, and from Haiku.
+
+WWW: https://github.com/Samsung/rlottie
diff --git a/graphics/rlottie/pkg-plist b/graphics/rlottie/pkg-plist
new file mode 100644
index 000000000000..a7d2922ea530
--- /dev/null
+++ b/graphics/rlottie/pkg-plist
@@ -0,0 +1,13 @@
+bin/lottie2gif
+include/rlottie.h
+include/rlottie_capi.h
+include/rlottiecommon.h
+lib/cmake/rlottie/rlottieConfig.cmake
+lib/cmake/rlottie/rlottieConfigVersion.cmake
+lib/cmake/rlottie/rlottieTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/rlottie/rlottieTargets.cmake
+lib/librlottie-image-loader.so
+lib/librlottie.so
+lib/librlottie.so.0
+lib/librlottie.so.0.2
+libdata/pkgconfig/rlottie.pc