aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2022-01-27 14:41:26 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2022-01-27 14:56:17 +0000
commit7aaabb9df576d7bff7c93ffea23018019781a5d6 (patch)
treee34a15d581d6ae7a210b5631f3e292bc0104766b
parent33b83935a48c5f12801f863257d84b7a5e4fd7cb (diff)
downloadports-7aaabb9df576d7bff7c93ffea23018019781a5d6.tar.gz
ports-7aaabb9df576d7bff7c93ffea23018019781a5d6.zip
deskutils/kodaskanna: new port, barcode and qr-code scanner
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/kodaskanna/Makefile25
-rw-r--r--deskutils/kodaskanna/distinfo3
-rw-r--r--deskutils/kodaskanna/pkg-descr11
-rw-r--r--deskutils/kodaskanna/pkg-plist13
5 files changed, 53 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index e51aff7c6c66..912f5e412e07 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -140,6 +140,7 @@
SUBDIR += kmail
SUBDIR += kmail-account-wizard
SUBDIR += knotes
+ SUBDIR += kodaskanna
SUBDIR += kongress
SUBDIR += kontact
SUBDIR += korganizer
diff --git a/deskutils/kodaskanna/Makefile b/deskutils/kodaskanna/Makefile
new file mode 100644
index 000000000000..b86a6ff44603
--- /dev/null
+++ b/deskutils/kodaskanna/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= kodaskanna
+DISTVERSION= 0.1.0
+CATEGORIES= deskutils
+MASTER_SITES= KDE/unstable/${PORTNAME}/${DISTVERSION}/src
+
+MAINTAINER= adridg@FreeBSD.org
+COMMENT= Barcode and QR-core scanner
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/LICENSES/LGPL-2.1-or-later.txt
+
+LIB_DEPENDS= libZXing.so.1:textproc/zxing-cpp
+
+USES= cmake compiler:c++17-lang gl kde:5 pkgconfig qt:5 tar:xz xorg
+USE_GL= gl
+USE_XORG= x11
+USE_QT= concurrent core dbus declarative gui \
+ multimedia network quickcontrols quickcontrols2 \
+ widgets xml \
+ buildtools_build qmake_build
+USE_KDE= auth codecs config configwidgets coreaddons i18n \
+ kio purpose service widgetsaddons windowsystem \
+ ecm_build
+
+.include <bsd.port.mk>
diff --git a/deskutils/kodaskanna/distinfo b/deskutils/kodaskanna/distinfo
new file mode 100644
index 000000000000..7067c1949065
--- /dev/null
+++ b/deskutils/kodaskanna/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1643278462
+SHA256 (kodaskanna-0.1.0.tar.xz) = 2860cfdae922a29749421f3b4e3281ef88fc5713002345bc725082fb47cd627f
+SIZE (kodaskanna-0.1.0.tar.xz) = 40656
diff --git a/deskutils/kodaskanna/pkg-descr b/deskutils/kodaskanna/pkg-descr
new file mode 100644
index 000000000000..889bfc59f72a
--- /dev/null
+++ b/deskutils/kodaskanna/pkg-descr
@@ -0,0 +1,11 @@
+Kodaskanna is a utility for reading data from 1D/2D codes (e.g. QR
+codes or bar codes) and making the data available for further processing.
+
+This initial 0.1.0 release supports scanning codes in static images. The image
+input files (can be also non-local ones) can be either passed as argument on
+the command line or manually selected via a file picker, pasted from the
+clipboard or dropped by DnD. The extracted content can then be exported to the
+clipboard or as a file. The version also provides integration via the Dolphin
+context menu for image files and by a KDE Purpose "Export" plugin.
+
+WWW: https://invent.kde.org/graphics/kodaskanna
diff --git a/deskutils/kodaskanna/pkg-plist b/deskutils/kodaskanna/pkg-plist
new file mode 100644
index 000000000000..0bc312495291
--- /dev/null
+++ b/deskutils/kodaskanna/pkg-plist
@@ -0,0 +1,13 @@
+bin/kodaskanna
+%%QT_PLUGINDIR%%/kf5/purpose/kodaskannaplugin.so
+share/applications/org.kde.kodaskanna.desktop
+share/icons/hicolor/48x48/apps/kodaskanna.svg
+share/kservices5/ServiceMenus/kodaskanna_scan_image.desktop
+share/locale/ca/LC_MESSAGES/kodaskanna.mo
+share/locale/es/LC_MESSAGES/kodaskanna.mo
+share/locale/nl/LC_MESSAGES/kodaskanna.mo
+share/locale/sk/LC_MESSAGES/kodaskanna.mo
+share/locale/sl/LC_MESSAGES/kodaskanna.mo
+share/locale/sv/LC_MESSAGES/kodaskanna.mo
+share/locale/uk/LC_MESSAGES/kodaskanna.mo
+share/metainfo/org.kde.kodaskanna.appdata.xml