aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-14 15:48:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-14 16:09:38 +0000
commit7ab6a568f37aeec1fe369172170fcc39fd1c688d (patch)
tree179885129c244a89c1318b0574ace79dc37172f2
parent1807856ac1faca5c29a05f8ddb5f9ca2126e0e49 (diff)
downloadports-7ab6a568f37aeec1fe369172170fcc39fd1c688d.tar.gz
ports-7ab6a568f37aeec1fe369172170fcc39fd1c688d.zip
textproc/py-pyexcel-xls: Add py-pyexcel-xls 0.6.2
pyexcel-xls is a tiny wrapper library to read, manipulate and write data in xls format and it can read xlsx and xlsm fromat. You are likely to use it with pyexcel. WWW: https://github.com/pyexcel/pyexcel-xls
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-pyexcel-xls/Makefile24
-rw-r--r--textproc/py-pyexcel-xls/distinfo3
-rw-r--r--textproc/py-pyexcel-xls/files/patch-setup.py11
-rw-r--r--textproc/py-pyexcel-xls/pkg-descr5
5 files changed, 44 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 967ef58e7652..a5193951a3fb 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1373,6 +1373,7 @@
SUBDIR += py-pyexcel-ezodf
SUBDIR += py-pyexcel-io
SUBDIR += py-pyexcel-ods3
+ SUBDIR += py-pyexcel-xls
SUBDIR += py-pygccxml
SUBDIR += py-pygments
SUBDIR += py-pygments-25
diff --git a/textproc/py-pyexcel-xls/Makefile b/textproc/py-pyexcel-xls/Makefile
new file mode 100644
index 000000000000..9914554ceec8
--- /dev/null
+++ b/textproc/py-pyexcel-xls/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pyexcel-xls
+PORTVERSION= 0.6.2
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Read, manipulate and write data in xls format
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyexcel-io>=0.6.2:textproc/py-pyexcel-io@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xlrd>=0:textproc/py-xlrd@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xlwt>=0:textproc/py-xlwt@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-pyexcel-xls/distinfo b/textproc/py-pyexcel-xls/distinfo
new file mode 100644
index 000000000000..7ab86fb1c663
--- /dev/null
+++ b/textproc/py-pyexcel-xls/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1625585436
+SHA256 (pyexcel-xls-0.6.2.tar.gz) = 2fbf66e8df88051eaaa9745be433903d18db819ddd3a987c992ead1d68b7feb5
+SIZE (pyexcel-xls-0.6.2.tar.gz) = 54339
diff --git a/textproc/py-pyexcel-xls/files/patch-setup.py b/textproc/py-pyexcel-xls/files/patch-setup.py
new file mode 100644
index 000000000000..734ef40dc381
--- /dev/null
+++ b/textproc/py-pyexcel-xls/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2020-12-12 22:34:25 UTC
++++ setup.py
+@@ -69,7 +69,7 @@ PYTHON_REQUIRES = ">=3.6"
+
+ INSTALL_REQUIRES = [
+ "pyexcel-io>=0.6.2",
+- "xlrd<2",
++ "xlrd",
+ "xlwt",
+ ]
+ SETUP_COMMANDS = {}
diff --git a/textproc/py-pyexcel-xls/pkg-descr b/textproc/py-pyexcel-xls/pkg-descr
new file mode 100644
index 000000000000..ea46ffa380f0
--- /dev/null
+++ b/textproc/py-pyexcel-xls/pkg-descr
@@ -0,0 +1,5 @@
+pyexcel-xls is a tiny wrapper library to read, manipulate and write data in xls
+format and it can read xlsx and xlsm fromat. You are likely to use it with
+pyexcel.
+
+WWW: https://github.com/pyexcel/pyexcel-xls