aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2022-10-16 07:01:12 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2022-10-16 07:12:42 +0000
commit7abbbd41759ae4e7e424a9204228f90feb7a62e9 (patch)
tree9a2ee9ac6e149276647e16fa6efefe48eec57023
parent2b1e7456fbf43223047cecdd2d95c5cf55926de5 (diff)
downloadports-7abbbd41759ae4e7e424a9204228f90feb7a62e9.tar.gz
ports-7abbbd41759ae4e7e424a9204228f90feb7a62e9.zip
Revert "textproc/apache-solr: Update version 8.11.2=>9.0.0"
This reverts commit b224cb40ad545da1f09dcf0d8bafb8baf0e1b110. This upgrade break solr installation as additional work may be required to get the new version with existing collections working.
-rw-r--r--textproc/apache-solr/Makefile18
-rw-r--r--textproc/apache-solr/distinfo6
-rw-r--r--textproc/apache-solr/files/patch-bin_solr14
-rw-r--r--textproc/apache-solr/files/pkg-message.in12
4 files changed, 24 insertions, 26 deletions
diff --git a/textproc/apache-solr/Makefile b/textproc/apache-solr/Makefile
index 027cc18dabd4..8e864555dd08 100644
--- a/textproc/apache-solr/Makefile
+++ b/textproc/apache-solr/Makefile
@@ -1,8 +1,9 @@
PORTNAME= apache-solr
-PORTVERSION= 9.0.0
+PORTVERSION= 8.11.2
PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= textproc java
-MASTER_SITES= https://archive.apache.org/dist/solr/solr/${PORTVERSION}/
+MASTER_SITES= https://archive.apache.org/dist/lucene/solr/${PORTVERSION}/
DISTNAME= solr-${PORTVERSION}
MAINTAINER= mfechner@FreeBSD.org
@@ -14,22 +15,19 @@ LICENSE= APACHE20
RUN_DEPENDS= bash:shells/bash
USES= cpe tar:tgz
-CPE_VENDOR= apache
-CPE_PRODUCT= solr
USE_JAVA= yes
JAVA_VERSION= 11+
JAVA_RUN= yes
-USE_RC_SUBR= solr
-
-NO_ARCH= yes
NO_BUILD= yes
-
+NO_ARCH= yes
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
SUB_FILES= pkg-message
-
+USE_RC_SUBR= solr
USERS= solr
GROUPS= ${USERS}
-PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+CPE_PRODUCT= solr
+CPE_VENDOR= apache
OPTIONS_DEFINE= JTS
OPTIONS_SUB= yes
diff --git a/textproc/apache-solr/distinfo b/textproc/apache-solr/distinfo
index 76634295a4da..e72f763a3c70 100644
--- a/textproc/apache-solr/distinfo
+++ b/textproc/apache-solr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1665150331
-SHA256 (solr-9.0.0.tgz) = fd1ddf07e2a25fffee2f398926de7889275bdd2520e97b50402c12125d39581e
-SIZE (solr-9.0.0.tgz) = 223857836
+TIMESTAMP = 1655708783
+SHA256 (solr-8.11.2.tgz) = 54d6ebd392942f0798a60d50a910e26794b2c344ee97c2d9b50e678a7066d3a6
+SIZE (solr-8.11.2.tgz) = 218171227
diff --git a/textproc/apache-solr/files/patch-bin_solr b/textproc/apache-solr/files/patch-bin_solr
index 1c15691df53e..0ea5bdcbddd3 100644
--- a/textproc/apache-solr/files/patch-bin_solr
+++ b/textproc/apache-solr/files/patch-bin_solr
@@ -1,6 +1,6 @@
---- bin/solr.orig 2022-04-25 20:37:26 UTC
+--- bin/solr.orig 2020-10-28 09:40:06 UTC
+++ bin/solr
-@@ -2269,13 +2269,12 @@ function start_solr() {
+@@ -2255,13 +2255,12 @@ function start_solr() {
echo ""
fi
# no lsof on cygwin though
@@ -10,19 +10,19 @@
(loops=0
while true
do
-- running=$(lsof -t -PniTCP:$SOLR_PORT -sTCP:LISTEN || :)
+- running=$(lsof -t -PniTCP:$SOLR_PORT -sTCP:LISTEN)
+ running=$(sockstat -ls -P tcp -p $SOLR_PORT | grep LISTEN)
- if [ -z "${running:-}" ]; then
- slept=$((loops * 2))
+ if [ -z "$running" ]; then
+ slept=$((loops * 2))
if [ $slept -lt $SOLR_START_WAIT ]; then
-@@ -2293,13 +2292,6 @@ function start_solr() {
+@@ -2279,13 +2278,6 @@ function start_solr() {
fi
done) &
spinner $!
- else
- echo -e "NOTE: Please install lsof as this script needs it to determine if Solr is listening on port $SOLR_PORT."
- sleep 10
-- SOLR_PID=`ps auxww | grep start\.jar | awk "/\-Djetty\.port=$SOLR_PORT/"' {print $2}' | sort -r`
+- SOLR_PID=`ps auxww | grep start\.jar | grep -w "\-Djetty\.port=$SOLR_PORT" | grep -v grep | awk '{print $2}' | sort -r`
- echo -e "\nStarted Solr server on port $SOLR_PORT (pid=$SOLR_PID). Happy searching!\n"
- return;
- fi
diff --git a/textproc/apache-solr/files/pkg-message.in b/textproc/apache-solr/files/pkg-message.in
index 4ff8a03f0ec2..9a5826983431 100644
--- a/textproc/apache-solr/files/pkg-message.in
+++ b/textproc/apache-solr/files/pkg-message.in
@@ -14,6 +14,11 @@ http://lucene.apache.org/solr/resources.html#documentation
The port is configured to listen only on localhost, port 8983.
+To have a working initial config, use:
+
+cp -R %%LOCALBASE%%/solr/example/example-DIH/solr/solr /var/db/solr/
+chown -R solr /var/db/solr/solr
+
To rotate solr log files include /var/log/solr/ to your log rotation
configuration.
@@ -32,14 +37,9 @@ If you would like to change logging, copy:
cp %%LOCALBASE%%/solr/server/resources/log4j2.xml /var/db/solr/
Change it and make sure it is loaded in %%LOCALBASE%%/etc/solr.in.sh.
-Data Import Handler (DIH) has been removed from the base solr and is
-available as independent module which can be installed with solr
-package manager. The current repo is available at:
-https://github.com/rohitbemax/dataimporthandler
-
Make also sure to always check the manual if you need to modify your
configs or schemas:
-https://solr.apache.org/guide/9_0/solr-upgrade-notes.html
+https://solr.apache.org/guide/8_9/solr-upgrade-notes.html
EOM
}
]