aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 08:42:47 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 09:04:43 +0000
commit7bd94ee3ef9d2b2683bd1610e6764857d973a137 (patch)
treeffc4b7c888ea32140a25f60d7a98eb96482545b5
parent9c9fda1b69feba35885e1b85876a14904e693e85 (diff)
downloadports-7bd94ee3ef9d2b2683bd1610e6764857d973a137.tar.gz
ports-7bd94ee3ef9d2b2683bd1610e6764857d973a137.zip
devel/py-notebook-shim: Update to 0.2.0
-rw-r--r--devel/py-notebook-shim/Makefile7
-rw-r--r--devel/py-notebook-shim/distinfo6
-rw-r--r--devel/py-notebook-shim/files/setup.py38
3 files changed, 46 insertions, 5 deletions
diff --git a/devel/py-notebook-shim/Makefile b/devel/py-notebook-shim/Makefile
index f77f70e18b0b..3013a6673cb8 100644
--- a/devel/py-notebook-shim/Makefile
+++ b/devel/py-notebook-shim/Makefile
@@ -1,5 +1,5 @@
PORTNAME= notebook-shim
-PORTVERSION= 0.1.0
+PORTVERSION= 0.2.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,11 +12,14 @@ WWW= https://github.com/jupyter/notebook_shim
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jupyter-server>=1.8<2:devel/py-jupyter-server@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jupyter-server>=1.8<3:devel/py-jupyter-server@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+
.include <bsd.port.mk>
diff --git a/devel/py-notebook-shim/distinfo b/devel/py-notebook-shim/distinfo
index e2dc59d98119..864a25850816 100644
--- a/devel/py-notebook-shim/distinfo
+++ b/devel/py-notebook-shim/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1647264402
-SHA256 (notebook_shim-0.1.0.tar.gz) = 7897e47a36d92248925a2143e3596f19c60597708f7bef50d81fcd31d7263e85
-SIZE (notebook_shim-0.1.0.tar.gz) = 12275
+TIMESTAMP = 1669057785
+SHA256 (notebook_shim-0.2.0.tar.gz) = fdb81febb05932c6d19e44e10382ce05469cac5e1b6e99b49be6159ddb5e4804
+SIZE (notebook_shim-0.2.0.tar.gz) = 12063
diff --git a/devel/py-notebook-shim/files/setup.py b/devel/py-notebook-shim/files/setup.py
new file mode 100644
index 000000000000..3a885fabfada
--- /dev/null
+++ b/devel/py-notebook-shim/files/setup.py
@@ -0,0 +1,38 @@
+# -*- coding: utf-8 -*-
+from setuptools import setup
+
+setup(
+ name='notebook-shim',
+ version='%%PORTVERSION%%',
+ description='A shim layer for notebook traits and config',
+ long_description='# Notebook Shim\n\nThis project provides a way for JupyterLab and other frontends to switch to [Jupyter Server](https://github.com/jupyter/jupyter_server/) for their Python Web application backend.\n\n## Basic Usage\n\nInstall from PyPI:\n\n```\npip install notebook_shim\n```\n\nThis will automatically enable the extension in Jupyter Server.\n\n## Usage\n\nThis project also includes an API for shimming traits that moved from `NotebookApp` in to `ServerApp` in Jupyter Server. This can be used by applications that subclassed `NotebookApp` to leverage the Python server backend of Jupyter Notebooks. Such extensions should *now* switch to `ExtensionApp` API in Jupyter Server and add `NotebookConfigShimMixin` in their inheritance list to properly handle moved traits.\n\nFor example, an application class that previously looked like:\n\n```python\nfrom notebook.notebookapp import NotebookApp\n\nclass MyApplication(NotebookApp):\n```\n\nshould switch to look something like:\n\n```python\nfrom jupyter_server.extension.application import ExtensionApp\nfrom notebook_shim.shim import NotebookConfigShimMixin\n\nclass MyApplication(NotebookConfigShimMixin, ExtensionApp):\n```',
+ author_email='Jupyter Development Team <jupyter@googlegroups.com>',
+ classifiers=[
+ 'Framework :: Jupyter',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Science/Research',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: BSD License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3 :: Only',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ ],
+ install_requires=[
+ 'jupyter-server<3,>=1.8',
+ ],
+ extras_require={
+ 'test': [
+ 'pytest',
+ 'pytest-console-scripts',
+ 'pytest-tornasync',
+ ],
+ },
+ packages=[
+ 'notebook_shim',
+ 'notebook_shim.tests',
+ ],
+)