aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2022-11-01 01:23:52 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2022-11-01 01:23:52 +0000
commit7c661db3cfcf8989a1b409e0955cd807dff1517e (patch)
tree0ccc47c66a3503d71ab2bd6951178095bf979e98
parent932ed6a1a14f487ea6c635ab528b9a9d205d991d (diff)
downloadports-7c661db3cfcf8989a1b409e0955cd807dff1517e.tar.gz
ports-7c661db3cfcf8989a1b409e0955cd807dff1517e.zip
math/octave-forge-csg-toolkit: Use smarter method to set CXXFLAGS.
-rw-r--r--math/octave-forge-csg-toolkit/Makefile7
-rw-r--r--math/octave-forge-csg-toolkit/files/patch-Makefile11
2 files changed, 6 insertions, 12 deletions
diff --git a/math/octave-forge-csg-toolkit/Makefile b/math/octave-forge-csg-toolkit/Makefile
index ea9bc73a08a9..ce09c981d69c 100644
--- a/math/octave-forge-csg-toolkit/Makefile
+++ b/math/octave-forge-csg-toolkit/Makefile
@@ -1,4 +1,5 @@
PORTNAME= octave-forge-csg-toolkit
+PORTREVISION= 1
DISTVERSIONPREFIX= v
DISTVERSION= 1.2.3
CATEGORIES= math
@@ -30,4 +31,8 @@ post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${OCTAVE_DISTNAME}.tar.gz ${OCTSRC}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+CXXFLAGS+= -stdlib=libstdc++
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-csg-toolkit/files/patch-Makefile b/math/octave-forge-csg-toolkit/files/patch-Makefile
deleted file mode 100644
index 11e05c1852e5..000000000000
--- a/math/octave-forge-csg-toolkit/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2022-10-31 00:26:54 UTC
-+++ Makefile
-@@ -4,7 +4,7 @@ all:
- $(MKOCTFILE) readObj.cc
- $(MKOCTFILE) writeObj.cc
- $(MKOCTFILE) longbone_maxDistance.cc
-- $(MKOCTFILE) longbone_Registration.cc
-+ $(MKOCTFILE) -stdlib=libstdc++ longbone_Registration.cc
- $(MKOCTFILE) meshArea.cc
- $(MKOCTFILE) meshBarycenter.cc
- $(MKOCTFILE) meshSection.cc