aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-16 12:03:41 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-16 12:03:41 +0000
commit7c696d31ec73f1e18d79d3f1a532a989e15abb80 (patch)
tree22327ef188a78437f47c3cd23f5e999f0f803ab1
parent8e3190be54d17eb68c866952f86f765c3aa898f5 (diff)
downloadports-7c696d31ec73f1e18d79d3f1a532a989e15abb80.tar.gz
ports-7c696d31ec73f1e18d79d3f1a532a989e15abb80.zip
multimedia/libmpeg2: fix build on powerpc
AltiVec code is broken on powerpc: motion_comp_altivec.c:48:12: warning: implicit declaration of function 'vec_ld' is invalid in C99 [-Wimplicit-function-declaration] return vec_ld (A, (uint8_t *)B); ^ motion_comp_altivec.c:48:34: warning: cast from 'const unsigned char *' to 'unsigned char *' drops const qualifier [-Wcast-qual] return vec_ld (A, (uint8_t *)B); ^ motion_comp_altivec.c:48:12: error: returning 'int' from a function with incompatible result type 'vector_u8_t' (vector of 16 'unsigned char' values) return vec_ld (A, (uint8_t *)B);
-rw-r--r--multimedia/libmpeg2/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/multimedia/libmpeg2/Makefile b/multimedia/libmpeg2/Makefile
index 00e69336412b..313f05814412 100644
--- a/multimedia/libmpeg2/Makefile
+++ b/multimedia/libmpeg2/Makefile
@@ -14,6 +14,7 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-shared
+CFLAGS_powerpc= -mno-altivec
LDFLAGS_armv6= -Wl,-z,notext
LDFLAGS_armv7= -Wl,-z,notext