aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-26 08:50:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-27 08:58:51 +0000
commit7d164f5ed589c5c43d66ab12ecc1ea45e6385ee4 (patch)
tree19e53d2d6b40cb1df76b1a7f4b1d4515c5c42379
parentc3737fc68abe81679e22ac2c255bad3b383c3e4b (diff)
downloadports-7d164f5ed589c5c43d66ab12ecc1ea45e6385ee4.tar.gz
ports-7d164f5ed589c5c43d66ab12ecc1ea45e6385ee4.zip
math/py-disjoint-set: New port: Disjoint set data structure implementation for Python
-rw-r--r--math/Makefile1
-rw-r--r--math/py-disjoint-set/Makefile19
-rw-r--r--math/py-disjoint-set/distinfo3
-rw-r--r--math/py-disjoint-set/pkg-descr2
4 files changed, 25 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 33346fa9eeb9..7d8a1a8c3f2f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -898,6 +898,7 @@
SUBDIR += py-cypari2
SUBDIR += py-deap
SUBDIR += py-dionysus
+ SUBDIR += py-disjoint-set
SUBDIR += py-docplex
SUBDIR += py-ducc0
SUBDIR += py-ecos
diff --git a/math/py-disjoint-set/Makefile b/math/py-disjoint-set/Makefile
new file mode 100644
index 000000000000..fa43039b492c
--- /dev/null
+++ b/math/py-disjoint-set/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= disjoint-set
+DISTVERSION= 0.7.3
+CATEGORIES= math
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Disjoint set data structure implementation for Python
+WWW= https://github.com/mrapacz/disjoint-set
+
+LICENSE= MIT
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-disjoint-set/distinfo b/math/py-disjoint-set/distinfo
new file mode 100644
index 000000000000..8d0ea2251903
--- /dev/null
+++ b/math/py-disjoint-set/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674722387
+SHA256 (disjoint_set-0.7.3.tar.gz) = cc09320b35d5a5bb36ceba86ab885b073340d0ba05cd92e9bd413fbea026162a
+SIZE (disjoint_set-0.7.3.tar.gz) = 3714
diff --git a/math/py-disjoint-set/pkg-descr b/math/py-disjoint-set/pkg-descr
new file mode 100644
index 000000000000..1bfa11ebbd03
--- /dev/null
+++ b/math/py-disjoint-set/pkg-descr
@@ -0,0 +1,2 @@
+disjoint-set is a DisjointSet (a.k.a. union-find data structure or merge-find
+set) implementation for Python.