aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-11-23 08:19:43 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-11-23 10:15:48 +0000
commit7d1ed4c1a3936a37890aad7b07094eb1904be02a (patch)
treeec99139e1358052cbcb19e62ef63a784b2ec3fe2
parenta92ca1451c52c0ab348db042b0d96690440b5109 (diff)
downloadports-7d1ed4c1a3936a37890aad7b07094eb1904be02a.tar.gz
ports-7d1ed4c1a3936a37890aad7b07094eb1904be02a.zip
graphics/opencv: explicitely disable support for graphics/tesseract
Since the update of graphics/tesseract to 4.1.3 in 3f1cf94980fdec66bdb115c46c94635ec3b54572 the configure script of opencv now can find tesseract support, however in a broken state. For now, disable tesseract in graphics/opencv explicitely, so that people building in an unclean environment with tesseract possibly installed can still build opencv. In the future, this will be replaced by an option toggle and fixed properly. PR: 259930 Reported by: rhurlin
-rw-r--r--graphics/opencv/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 1d6d55cca4cd..84f5c2fb9f66 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -38,7 +38,8 @@ GH_TAGNAME= v0.1.1f:ade \
CMAKE_ON= OPENCV_GENERATE_PKGCONFIG
CMAKE_OFF= OPENCV_GENERATE_SETUPVARS \
BUILD_opencv_python2 \
- BUILD_TESTS
+ BUILD_TESTS \
+ WITH_TESSERACT
CMAKE_ARGS= -DOPENCV_EXTRA_MODULES_PATH="${WRKSRC}/contrib/modules"
DATADIR= ${PREFIX}/share/${PORTNAME}4