aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerhii (Sergey) Kozlov <skozlov@FreeBSD.org>2023-02-05 19:48:29 +0000
committerSerhii (Sergey) Kozlov <skozlov@FreeBSD.org>2023-02-05 19:53:56 +0000
commit7d484dbea927a3ede696fb4aefed3cbc6631006b (patch)
tree7ad237261f5beb9b81598aae9d55d44699c09db2
parentf5890bd3cbc66a805bfc04a1a45688b5a3e68c50 (diff)
downloadports-7d484dbea927a3ede696fb4aefed3cbc6631006b.tar.gz
ports-7d484dbea927a3ede696fb4aefed3cbc6631006b.zip
print/p910nd: Moved to github
The distfiles were moved to github, so change the port accordingly. Other changes: - Build via embedded gmake Makefile - Add LICENSE file path - Remove scripts from pkg-plist (not in the distribution anymore) - Smaller manpage fixes PR: 269109 Reported by: Daniel Engberg <diizzy@FreeBSD.org>
-rw-r--r--print/p910nd/Makefile19
-rw-r--r--print/p910nd/distinfo5
-rw-r--r--print/p910nd/files/patch-Makefile14
-rw-r--r--print/p910nd/files/patch-p910nd.814
-rw-r--r--print/p910nd/pkg-plist2
5 files changed, 35 insertions, 19 deletions
diff --git a/print/p910nd/Makefile b/print/p910nd/Makefile
index cf021c6d34e3..1649d84a9a88 100644
--- a/print/p910nd/Makefile
+++ b/print/p910nd/Makefile
@@ -1,31 +1,34 @@
PORTNAME= p910nd
PORTVERSION= 0.97
+PORTREVISION= 1
CATEGORIES= print net
-MASTER_SITES= SF
MAINTAINER= skozlov@FreeBSD.org
COMMENT= Port 9100+n printer daemon
-WWW= http://p910nd.sourceforge.net/
+WWW= https://github.com/kenyapcomau/p910nd
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USES= tar:bzip2
+USES= gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= kenyapcomau
+
+ALL_TARGET= ${PORTNAME}
USE_RC_SUBR= p910nd
P910ND_RUNDIR= /var/run/${PORTNAME}
PLIST_SUB= P910ND_RUNDIR=${P910ND_RUNDIR}
-CFLAGS+= -DLOCKFILE_DIR="\"${P910ND_RUNDIR}\"" -DUSE_WRAP
+MAKE_ENV+= USE_WRAP=yes
-do-build:
- ${CC} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c ${CFLAGS}
+CFLAGS+= -DLOCKFILE_DIR='\"${P910ND_RUNDIR}\"'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${MANPREFIX}/man/man8
- ${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/*.pl ${STAGEDIR}${DATADIR}
${MKDIR} ${STAGEDIR}${P910ND_RUNDIR}
.include <bsd.port.mk>
diff --git a/print/p910nd/distinfo b/print/p910nd/distinfo
index 25bfa7efde10..d61e757522c3 100644
--- a/print/p910nd/distinfo
+++ b/print/p910nd/distinfo
@@ -1,2 +1,3 @@
-SHA256 (p910nd-0.97.tar.bz2) = 4ac980a3ae24babae6f70f0a692625ece03a4a92c357fbb10d2e368386c3c26f
-SIZE (p910nd-0.97.tar.bz2) = 20613
+TIMESTAMP = 1675622190
+SHA256 (kenyapcomau-p910nd-0.97_GH0.tar.gz) = a1bcc2dd75bad4e00a9de5098dbd970e8380f978fc09292bcfa15852af6a6964
+SIZE (kenyapcomau-p910nd-0.97_GH0.tar.gz) = 21063
diff --git a/print/p910nd/files/patch-Makefile b/print/p910nd/files/patch-Makefile
new file mode 100644
index 000000000000..3b0fd688c6ec
--- /dev/null
+++ b/print/p910nd/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig 2022-02-08 05:54:54 UTC
++++ Makefile
+@@ -11,11 +11,6 @@ CROSS =
+ # GNU target string
+ CROSS =
+
+-CC = $(CROSS)gcc
+-STRIP = $(CROSS)strip
+-
+-CFLAGS += -O2 -Wall
+-
+ PROG = p910nd
+ MANPAGE = p910nd.8
+ INSTALL = install
diff --git a/print/p910nd/files/patch-p910nd.8 b/print/p910nd/files/patch-p910nd.8
index ea1211058da7..d10b1e9c94cd 100644
--- a/print/p910nd/files/patch-p910nd.8
+++ b/print/p910nd/files/patch-p910nd.8
@@ -1,6 +1,6 @@
---- p910nd.8.orig 2013-07-07 17:52:31.000000000 +0300
-+++ p910nd.8 2013-07-07 18:08:04.000000000 +0300
-@@ -11,7 +11,7 @@
+--- p910nd.8.orig 2022-02-08 05:54:54 UTC
++++ p910nd.8
+@@ -11,7 +11,7 @@ it is listening on to the corresponding printer port.
.I p910nd
is a small daemon that copies any data received on the port
it is listening on to the corresponding printer port.
@@ -9,7 +9,7 @@
but there is no reason why it could not be used on diskful hosts.
Port 9100 is copied to /dev/lp0, 9101 to /dev/lp1 and 9102 to /dev/lp2.
The default is port 9100 to /dev/lp0.
-@@ -30,15 +30,6 @@
+@@ -33,15 +33,6 @@ It will automatically detect if it is running under (x
can be run as a standalone daemon or from (x)inetd.
It will automatically detect if it is running under (x)inetd.
.LP
@@ -25,7 +25,7 @@
When running under (x)inetd, the
.I /etc/inetd.conf
entry should look something like this (with tcpwrappers protection):
-@@ -74,7 +65,7 @@
+@@ -77,7 +68,7 @@ need to set up an intermediate queue anyway to provide
spooler and sending all jobs to this host. You will probably
need to set up an intermediate queue anyway to provide print job filtering.
.LP
@@ -34,12 +34,12 @@
Access control can be done with /etc/hosts.allow
and /etc/hosts.deny. The service name is p910nd.
.SH DIAGNOSTICS
-@@ -83,7 +74,7 @@
+@@ -86,7 +77,7 @@ printcap(5), hosts_access(5)
.SH "SEE ALSO"
printcap(5), hosts_access(5)
.SH FILES
-/var/run/p9100d.pid, /var/lock/subsys/p9100d, /etc/hosts.allow, /etc/hosts.deny
-+/var/run/p9100d.pid, /tmp/p9100d, /etc/hosts.allow, /etc/hosts.deny
++/var/run/p9100d.pid, /var/run/p9100d, /etc/hosts.allow, /etc/hosts.deny
.SH COPYRIGHT
.I p910nd
is under the GNU Public License Version 2
diff --git a/print/p910nd/pkg-plist b/print/p910nd/pkg-plist
index c8ba380e1725..0cc50ad899b3 100644
--- a/print/p910nd/pkg-plist
+++ b/print/p910nd/pkg-plist
@@ -1,5 +1,3 @@
man/man8/p910nd.8.gz
sbin/p910nd
-%%DATADIR%%/banner.pl
-%%DATADIR%%/client.pl
@dir %%P910ND_RUNDIR%%