aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2022-04-27 13:48:41 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2022-04-27 13:48:41 +0000
commit7e1885f8691a8bd275fc2bcfb4984c17a73f60d5 (patch)
treecd7ea145ed4094736bf930ebb7ee3ff7dec491a1
parent482f51d241ec65031c2acd4230a2fc919c0ea2f5 (diff)
downloadports-7e1885f8691a8bd275fc2bcfb4984c17a73f60d5.tar.gz
ports-7e1885f8691a8bd275fc2bcfb4984c17a73f60d5.zip
japanese/font-udev-gothic{,-nf}: Add new ports -- UDEV Gothic
-rw-r--r--japanese/Makefile2
-rw-r--r--japanese/font-udev-gothic-nf/Makefile54
-rw-r--r--japanese/font-udev-gothic-nf/distinfo3
-rw-r--r--japanese/font-udev-gothic-nf/pkg-descr4
-rw-r--r--japanese/font-udev-gothic/Makefile64
-rw-r--r--japanese/font-udev-gothic/distinfo3
-rw-r--r--japanese/font-udev-gothic/pkg-descr4
7 files changed, 134 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index f3d90c67b4d1..014c08baa360 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -107,6 +107,8 @@
SUBDIR += font-shinonome
SUBDIR += font-std
SUBDIR += font-takao
+ SUBDIR += font-udev-gothic
+ SUBDIR += font-udev-gothic-nf
SUBDIR += font-ume
SUBDIR += font-vlgothic
SUBDIR += freepwing
diff --git a/japanese/font-udev-gothic-nf/Makefile b/japanese/font-udev-gothic-nf/Makefile
new file mode 100644
index 000000000000..33823d2d403f
--- /dev/null
+++ b/japanese/font-udev-gothic-nf/Makefile
@@ -0,0 +1,54 @@
+PORTNAME= udev-gothic-nf
+PORTVERSION= 1.0.0
+PORTREVISION= 0
+CATEGORIES= japanese x11-fonts
+MASTER_SITES= https://github.com/yuru7/udev-gothic/releases/download/v${PORTVERSION}/
+PKGNAMEPREFIX= ja-font-
+DISTNAME= UDEVGothic_NF_v${DISTVERSION}
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= UDEV Gothic (Nerd Fonts)
+
+LICENSE= OFL11
+
+USES= fonts:fc zip
+NO_ARCH= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+OPTIONS_MULTI= FONT_FAMILY
+OPTIONS_MULTI_FONT_FAMILY= UDEV_GOTHIC_NF UDEV_GOTHIC_NFLG \
+ UDEV_GOTHIC_35NF UDEV_GOTHIC_35NFLG
+OPTIONS_DEFAULT= UDEV_GOTHIC_NF UDEV_GOTHIC_NFLG \
+ UDEV_GOTHIC_35NF UDEV_GOTHIC_35NFLG
+UDEV_GOTHIC_NF_DESC= UDEVGothicNF
+UDEV_GOTHIC_NFLG_DESC= UDEVGothicNFLG
+UDEV_GOTHIC_35NF_DESC= UDEVGothic35NF
+UDEV_GOTHIC_35NFLG_DESC= UDEVGothic35NFLG
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MUDEV_GOTHIC_NF}
+FONT_FAMILY+= UDEVGothicNF
+.endif
+.if ${PORT_OPTIONS:MUDEV_GOTHIC_NFLG}
+FONT_FAMILY+= UDEVGothicNFLG
+.endif
+.if ${PORT_OPTIONS:MUDEV_GOTHIC_35NF}
+FONT_FAMILY+= UDEVGothic35NF
+.endif
+.if ${PORT_OPTIONS:MUDEV_GOTHIC_35NFLG}
+FONT_FAMILY+= UDEVGothic35NFLG
+.endif
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+.for FAMILY in ${FONT_FAMILY}
+. for STYLE in Bold BoldItalic Italic Regular
+ ${INSTALL_DATA} ${WRKSRC}/${FAMILY}-${STYLE}.ttf \
+ ${STAGEDIR}${FONTSDIR}
+ @${ECHO_CMD} ${FONTSDIR}/${FAMILY}-${STYLE}.ttf >> ${TMPPLIST}
+. endfor
+.endfor
+
+.include <bsd.port.mk>
diff --git a/japanese/font-udev-gothic-nf/distinfo b/japanese/font-udev-gothic-nf/distinfo
new file mode 100644
index 000000000000..c76d6974bc2a
--- /dev/null
+++ b/japanese/font-udev-gothic-nf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1651059055
+SHA256 (UDEVGothic_NF_v1.0.0.zip) = c431f9ce6762c21cdc2b2f32481b1374babb2cf50dc5e949f27a8f7101ecceeb
+SIZE (UDEVGothic_NF_v1.0.0.zip) = 48311352
diff --git a/japanese/font-udev-gothic-nf/pkg-descr b/japanese/font-udev-gothic-nf/pkg-descr
new file mode 100644
index 000000000000..ffeda47dc33c
--- /dev/null
+++ b/japanese/font-udev-gothic-nf/pkg-descr
@@ -0,0 +1,4 @@
+UDEV Gothic is a composite font of BIZ UD Gothic and
+JetBrains Mono (Nerd Fonts).
+
+WWW; https://github.com/yuru7/udev-gothic
diff --git a/japanese/font-udev-gothic/Makefile b/japanese/font-udev-gothic/Makefile
new file mode 100644
index 000000000000..823bc7ec9d28
--- /dev/null
+++ b/japanese/font-udev-gothic/Makefile
@@ -0,0 +1,64 @@
+PORTNAME= udev-gothic
+PORTVERSION= 1.0.0
+PORTREVISION= 0
+CATEGORIES= japanese x11-fonts
+MASTER_SITES= https://github.com/yuru7/udev-gothic/releases/download/v${PORTVERSION}/
+PKGNAMEPREFIX= ja-font-
+DISTNAME= UDEVGothic_v${DISTVERSION}
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= UDEV Gothic
+
+LICENSE= OFL11
+
+USES= fonts:fc zip
+NO_ARCH= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+OPTIONS_MULTI= FONT_FAMILY
+OPTIONS_MULTI_FONT_FAMILY= UDEV_GOTHIC UDEV_GOTHIC_JPDOC UDEV_GOTHIC_LG \
+ UDEV_GOTHIC_35 UDEV_GOTHIC_35JPDOC \
+ UDEV_GOTHIC_35LG
+OPTIONS_DEFAULT= UDEV_GOTHIC UDEV_GOTHIC_JPDOC UDEV_GOTHIC_LG \
+ UDEV_GOTHIC_35 UDEV_GOTHIC_35JPDOC \
+ UDEV_GOTHIC_35LG
+UDEV_GOTHIC_DESC= UDEVGothicNF
+UDEV_GOTHIC_JPDOC_DESC= UDEVGothicJPDOC
+UDEV_GOTHIC_LG_DESC= UDEVGothicLG
+UDEV_GOTHIC_35_DESC= UDEVGothic35
+UDEV_GOTHIC_35JPDOC_DESC= UDEVGothic35JPDOC
+UDEV_GOTHIC_35LG_DESC= UDEVGothic35LG
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MUDEV_GOTHIC}
+FONT_FAMILY+= UDEVGothic
+.endif
+.if ${PORT_OPTIONS:MUDEV_GOTHIC_JPDOC}
+FONT_FAMILY+= UDEVGothicJPDOC
+.endif
+.if ${PORT_OPTIONS:MUDEV_GOTHIC_LG}
+FONT_FAMILY+= UDEVGothicLG
+.endif
+.if ${PORT_OPTIONS:MUDEV_GOTHIC_35}
+FONT_FAMILY+= UDEVGothic35
+.endif
+.if ${PORT_OPTIONS:MUDEV_GOTHIC_35JPDOC}
+FONT_FAMILY+= UDEVGothic35JPDOC
+.endif
+.if ${PORT_OPTIONS:MUDEV_GOTHIC_35LG}
+FONT_FAMILY+= UDEVGothic35LG
+.endif
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+.for FAMILY in ${FONT_FAMILY}
+. for STYLE in Bold BoldItalic Italic Regular
+ ${INSTALL_DATA} ${WRKSRC}/${FAMILY}-${STYLE}.ttf \
+ ${STAGEDIR}${FONTSDIR}
+ @${ECHO_CMD} ${FONTSDIR}/${FAMILY}-${STYLE}.ttf >> ${TMPPLIST}
+. endfor
+.endfor
+
+.include <bsd.port.mk>
diff --git a/japanese/font-udev-gothic/distinfo b/japanese/font-udev-gothic/distinfo
new file mode 100644
index 000000000000..a0200df2cf9a
--- /dev/null
+++ b/japanese/font-udev-gothic/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1651065718
+SHA256 (UDEVGothic_v1.0.0.zip) = f1b07d0c58a9d96fe665bd256d32e739a88796dc25d15441351c1c4b0e1908d6
+SIZE (UDEVGothic_v1.0.0.zip) = 61329453
diff --git a/japanese/font-udev-gothic/pkg-descr b/japanese/font-udev-gothic/pkg-descr
new file mode 100644
index 000000000000..ffeda47dc33c
--- /dev/null
+++ b/japanese/font-udev-gothic/pkg-descr
@@ -0,0 +1,4 @@
+UDEV Gothic is a composite font of BIZ UD Gothic and
+JetBrains Mono (Nerd Fonts).
+
+WWW; https://github.com/yuru7/udev-gothic