aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 00:22:16 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 00:44:36 +0000
commit7e96793e537ce41cea8480c99d3fecf41465f381 (patch)
tree00f87685dd2e63587bab7202004a8065b64c6919
parent83a8c2450b3cbd8825cd8077f7d80626cfe204d3 (diff)
downloadports-7e96793e537ce41cea8480c99d3fecf41465f381.tar.gz
ports-7e96793e537ce41cea8480c99d3fecf41465f381.zip
finance/py-yfinance: Update to 0.2.30
-rw-r--r--finance/py-yfinance/Makefile3
-rw-r--r--finance/py-yfinance/distinfo6
-rw-r--r--finance/py-yfinance/files/patch-setup.py11
3 files changed, 16 insertions, 4 deletions
diff --git a/finance/py-yfinance/Makefile b/finance/py-yfinance/Makefile
index cd8b14200cd1..41d58e6dfb92 100644
--- a/finance/py-yfinance/Makefile
+++ b/finance/py-yfinance/Makefile
@@ -1,5 +1,5 @@
PORTNAME= yfinance
-PORTVERSION= 0.2.28
+PORTVERSION= 0.2.30
CATEGORIES= finance python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,6 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.4:devel/py-appdirs@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}multitasking>=0.0.7:devel/py-multitasking@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=1.16.5,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>=1.3.0,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}peewee>=3.15.0:databases/py-peewee@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=2022.5,1:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.31:www/py-requests@${PY_FLAVOR}
diff --git a/finance/py-yfinance/distinfo b/finance/py-yfinance/distinfo
index 966afc199a6d..8cf6d7e0e496 100644
--- a/finance/py-yfinance/distinfo
+++ b/finance/py-yfinance/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1692211787
-SHA256 (yfinance-0.2.28.tar.gz) = be89cd2a4d55c0a2a6227c32915b355bde59f85c569dca9123320322445901ff
-SIZE (yfinance-0.2.28.tar.gz) = 63007
+TIMESTAMP = 1696001380
+SHA256 (yfinance-0.2.30.tar.gz) = 9b980cfb20beb903c4e3dee212de305f3d6fea96e5c571bf424239da974970fe
+SIZE (yfinance-0.2.30.tar.gz) = 63123
diff --git a/finance/py-yfinance/files/patch-setup.py b/finance/py-yfinance/files/patch-setup.py
new file mode 100644
index 000000000000..3e1a658ac247
--- /dev/null
+++ b/finance/py-yfinance/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2023-09-22 11:04:41 UTC
++++ setup.py
+@@ -62,7 +62,7 @@ setup(
+ install_requires=['pandas>=1.3.0', 'numpy>=1.16.5',
+ 'requests>=2.31', 'multitasking>=0.0.7',
+ 'lxml>=4.9.1', 'appdirs>=1.4.4', 'pytz>=2022.5',
+- 'frozendict>=2.3.4', 'peewee>=3.16.2',
++ 'frozendict>=2.3.4', 'peewee>=3.15.0',
+ 'beautifulsoup4>=4.11.1', 'html5lib>=1.1'],
+ # Note: Pandas.read_html() needs html5lib & beautifulsoup4
+ entry_points={