aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-04-22 14:22:24 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-04-22 14:32:55 +0000
commit7ebdbb52f8d7050fcfd6bbad5eac0ade8a52597e (patch)
tree47eb5d6685b37973cd6123d930e0bf32c769b993
parent0d7168d58b0c155de9ba1a297e9ba08e844f8e4c (diff)
downloadports-7ebdbb52f8d7050fcfd6bbad5eac0ade8a52597e.tar.gz
ports-7ebdbb52f8d7050fcfd6bbad5eac0ade8a52597e.zip
x11-toolkits/qt5-gui: unbreak on FreeBSD >= 13.0 armv[67]
/usr/bin/cc ... -fno-integrated-as ... ../3rdparty/pixman/pixman-arm-neon-asm.S -o .obj/pixman-arm-neon-asm.o cc: error: unable to execute command: Executable "as" doesn't exist! cc: error: assembler command failed with exit code 1 (use -v to see invocation) Reported by: pkg-fallout
-rw-r--r--x11-toolkits/qt5-gui/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/x11-toolkits/qt5-gui/Makefile b/x11-toolkits/qt5-gui/Makefile
index 1539528e6ef4..8cc7362c6252 100644
--- a/x11-toolkits/qt5-gui/Makefile
+++ b/x11-toolkits/qt5-gui/Makefile
@@ -10,7 +10,10 @@ COMMENT= Qt graphical user interface module
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
${LOCALBASE}/include/vulkan/vulkan.h:graphics/vulkan-headers \
${LOCALBASE}/include/xf86drm.h:graphics/libdrm \
- at-spi2-core>=0:accessibility/at-spi2-core
+ at-spi2-core>=0:accessibility/at-spi2-core \
+ ${BUILD_DEPENDS_${ARCH}}
+BUILD_DEPENDS_armv6= as:devel/binutils
+BUILD_DEPENDS_armv7= as:devel/binutils
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libevdev.so:devel/libevdev \
libfontconfig.so:x11-fonts/fontconfig \