aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:42:53 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:37 +0000
commit7ec51f4223a26c1323d1f2caac70f846cf9f12e8 (patch)
tree783842d319bb804ae7f69f2a618ff485e4c39304
parent5d5e2ca2e7fc8289fb65a3dc0a73e335baaa19a5 (diff)
downloadports-7ec51f4223a26c1323d1f2caac70f846cf9f12e8.tar.gz
ports-7ec51f4223a26c1323d1f2caac70f846cf9f12e8.zip
devel/py-flake8-black: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-flake8-black/Makefile8
-rw-r--r--devel/py-flake8-black/files/patch-pyproject.toml9
-rw-r--r--devel/py-flake8-black/files/setup.py3
3 files changed, 13 insertions, 7 deletions
diff --git a/devel/py-flake8-black/Makefile b/devel/py-flake8-black/Makefile
index 3767924a4f3c..77b2d6814710 100644
--- a/devel/py-flake8-black/Makefile
+++ b/devel/py-flake8-black/Makefile
@@ -1,5 +1,6 @@
PORTNAME= flake8-black
PORTVERSION= 0.3.6
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +12,13 @@ WWW= https://github.com/peterjc/flake8-black
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}black>=22.1.0:devel/py-black@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}flake8>=3:devel/py-flake8@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
@@ -25,7 +28,4 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tomli>=0:textproc/py-tomli@${PY_FLAVOR}
.endif
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
.include <bsd.port.post.mk>
diff --git a/devel/py-flake8-black/files/patch-pyproject.toml b/devel/py-flake8-black/files/patch-pyproject.toml
new file mode 100644
index 000000000000..08a0db3f490c
--- /dev/null
+++ b/devel/py-flake8-black/files/patch-pyproject.toml
@@ -0,0 +1,9 @@
+--- pyproject.toml.orig 2022-12-20 09:28:50 UTC
++++ pyproject.toml
+@@ -1,5 +1,5 @@
+ [build-system]
+-requires = ['pip>=21.3', 'setuptools>=61', 'wheel']
++requires = ['setuptools>=61', 'wheel']
+ build-backend = 'setuptools.build_meta'
+
+ [project]
diff --git a/devel/py-flake8-black/files/setup.py b/devel/py-flake8-black/files/setup.py
deleted file mode 100644
index 606849326a40..000000000000
--- a/devel/py-flake8-black/files/setup.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from setuptools import setup
-
-setup()