aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-04-24 20:27:12 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-05-07 18:38:48 +0000
commit7ecd176f65a556e852635b33bd30843c1ce31bb4 (patch)
tree28213e9c761395f9e1d638a69a30053b2d788abc
parentd994be1167ebf8a892784294af368ba14053150f (diff)
downloadports-7ecd176f65a556e852635b33bd30843c1ce31bb4.tar.gz
ports-7ecd176f65a556e852635b33bd30843c1ce31bb4.zip
devel/kyua: fix build with clang 16
Since clang 16 (and gcc 11) the default C++ standard is now gnu++17. Because devel/kyua's Makefile does not explicitly set its C++ standard, this leads to several errors: In file included from cli/cmd_about.cpp:29: In file included from ./cli/cmd_about.hpp:35: ./cli/common.hpp:71:14: error: no template named 'auto_ptr' in namespace 'std' typedef std::auto_ptr< cli_command > cli_command_ptr; ~~~~~^ In file included from cli/cmd_db_exec.cpp:29: In file included from ./cli/cmd_db_exec.hpp:37: ./cli/common.hpp:71:14: error: no template named 'auto_ptr' in namespace 'std' typedef std::auto_ptr< cli_command > cli_command_ptr; ~~~~~^ In file included from cli/cmd_db_migrate.cpp:29: In file included from ./cli/cmd_db_migrate.hpp:35: ./cli/common.hpp:71:14: error: no template named 'auto_ptr' in namespace 'std' typedef std::auto_ptr< cli_command > cli_command_ptr; ~~~~~^ In file included from cli/cmd_config.cpp:29: In file included from ./cli/cmd_config.hpp:35: ./cli/common.hpp:71:14: error: no template named 'auto_ptr' in namespace 'std' typedef std::auto_ptr< cli_command > cli_command_ptr; ~~~~~^ Add USE_CXXSTD=gnu++98 to avoid these errors. PR: 271054 Approved by: maintainer timeout (2 weeks) MFH: 2023Q2
-rw-r--r--devel/kyua/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/kyua/Makefile b/devel/kyua/Makefile
index 1c3ebd4a8895..bab190f32c06 100644
--- a/devel/kyua/Makefile
+++ b/devel/kyua/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kyua
PORTVERSION= 0.13
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 3
CATEGORIES= devel
MASTER_SITES= https://github.com/jmmv/kyua/releases/download/${PORTNAME}-${PORTVERSION}/ \
@@ -15,6 +15,7 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= liblutok.so:devel/lutok
USES= lua pkgconfig sqlite
+USE_CXXSTD= gnu++11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --docdir=${DOCSDIR} \