aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-06-02 16:07:36 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-06-05 11:14:02 +0000
commit7f8065adb4f9f7255fee3038c4b0eb8d598a09ce (patch)
tree21a46a4f90b6f7fee4235d3a19864fe2cfa51900
parent0008e7f947fd86ee143e0227b683d327cab1a33a (diff)
downloadports-7f8065adb4f9f7255fee3038c4b0eb8d598a09ce.tar.gz
ports-7f8065adb4f9f7255fee3038c4b0eb8d598a09ce.zip
editors/mle: update to 1.5.0
ChangeLog: https://github.com/adsr/mle/compare/v1.4.3...v1.5.0 PR: 264337 Reported by: as@php.net (maintainer)
-rw-r--r--editors/mle/Makefile26
-rw-r--r--editors/mle/distinfo6
2 files changed, 21 insertions, 11 deletions
diff --git a/editors/mle/Makefile b/editors/mle/Makefile
index 9fa2d1fe77c8..a4aa3cbf8e11 100644
--- a/editors/mle/Makefile
+++ b/editors/mle/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mle
DISTVERSIONPREFIX= v
-DISTVERSION= 1.4.3
+DISTVERSION= 1.5.0
CATEGORIES= editors
MAINTAINER= as@php.net
@@ -12,26 +12,26 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:devel/uthash
-LIB_DEPENDS= libpcre.so:devel/pcre \
- libtermbox.so:devel/termbox
+LIB_DEPENDS= libpcre.so:devel/pcre
TEST_DEPENDS= ${LOCALBASE}/bin/gpaste:sysutils/coreutils \
${LOCALBASE}/bin/grep:textproc/gnugrep \
bash:shells/bash \
gfind:misc/findutils
-USES= compiler:c11 gmake localbase:ldflags shebangfix lua:53
+USES= compiler:c11 gmake localbase:ldflags shebangfix lua:54
SHEBANG_FILES= tests/func/*.sh tests/run.sh
USE_GITHUB= yes
GH_ACCOUNT= adsr
-PLIST_FILES= bin/mle
TEST_TARGET= test
+PLIST_FILES= bin/mle
post-patch:
- @${REINPLACE_CMD} -e 's|lua5.3|lua53|g' ${WRKSRC}/mle.h
- @${REINPLACE_CMD} -e 's|lua5.3|lua-5.3|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|lua5.4|lua54|g' ${WRKSRC}/mle.h
+ @${REINPLACE_CMD} -e 's|lua5.4|lua-5.4|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-O0|-O2|g' ${WRKSRC}/Makefile
- # Tests.
+ # Fix shell commands in tests
@${REINPLACE_CMD} -e 's|find|gfind|g' \
-e 's|grep|${LOCALBASE}/bin/grep|g' \
${WRKSRC}/tests/run.sh \
@@ -39,6 +39,16 @@ post-patch:
@${REINPLACE_CMD} -e 's|p a s t e|g p a s t e|g' \
${WRKSRC}/tests/func/test_lua.sh
+ # Remove assertion that relies on UTF-8 codeset (fixed upstream)
+ @${REINPLACE_CMD} -e '/0wv/d' \
+ ${WRKSRC}/tests/unit/test_bline_insert.c
+
+ # Remove assertions that rely on GNU tooling output
+ @${REINPLACE_CMD} -e '/shell_line/d' \
+ ${WRKSRC}/tests/func/test_multi_cursor.sh
+ @${REINPLACE_CMD} -e '/byte_count/d' \
+ ${WRKSRC}/tests/func/test_coarse_undo.sh
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mle ${STAGEDIR}${PREFIX}/bin
diff --git a/editors/mle/distinfo b/editors/mle/distinfo
index b979f98afd64..3b22cb6f77dc 100644
--- a/editors/mle/distinfo
+++ b/editors/mle/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1582636451
-SHA256 (adsr-mle-v1.4.3_GH0.tar.gz) = 452b14d63f7d3ccd98263baec2e4840e4093cc42d1f9cedeaf45151b89ac5ff6
-SIZE (adsr-mle-v1.4.3_GH0.tar.gz) = 106221
+TIMESTAMP = 1654130400
+SHA256 (adsr-mle-v1.5.0_GH0.tar.gz) = 569316485fa3775d0bb7559ac176a63adb29467c7098b14c0072c821feb6226b
+SIZE (adsr-mle-v1.5.0_GH0.tar.gz) = 135463