aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2023-07-13 11:38:14 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2023-07-13 12:44:44 +0000
commit7fa24cff0d8a99e5d44839d4b358fafaf69cffbe (patch)
treee81e2615cfd02ff99b637efa73cba44de2c93cc7
parent0d0523564846a2f1a9320f1f2adc43eb60c2e304 (diff)
downloadports-7fa24cff0d8a99e5d44839d4b358fafaf69cffbe.tar.gz
ports-7fa24cff0d8a99e5d44839d4b358fafaf69cffbe.zip
security/gnupg: Fix dirmngr crash caused by gettext 0.22
Link the threading library after libgpg-error (and libgcrypt, which also links to libgpg-error) so the threading library is initialised before libgpg-error. The initialisation function of libgpg-error calls gettext functions that call threading functions (mutex locking). PR: 272472 Tested by: yasu
-rw-r--r--security/gnupg/Makefile1
-rw-r--r--security/gnupg/files/patch-dirmngr_Makefile.in12
2 files changed, 13 insertions, 0 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index da89e93fc2e4..ca13f0c944f9 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gnupg
DISTVERSION= 2.4.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= GNUPG
diff --git a/security/gnupg/files/patch-dirmngr_Makefile.in b/security/gnupg/files/patch-dirmngr_Makefile.in
new file mode 100644
index 000000000000..96607396e75d
--- /dev/null
+++ b/security/gnupg/files/patch-dirmngr_Makefile.in
@@ -0,0 +1,12 @@
+--- dirmngr/Makefile.in.orig 2023-07-04 14:09:03 UTC
++++ dirmngr/Makefile.in
+@@ -719,8 +719,8 @@ dirmngr_LDADD = $(libcommonpth) $(DNSLIBS) $(LIBASSUAN
+ @USE_LDAP_FALSE@ldaplibs =
+ @USE_LDAP_TRUE@ldaplibs = $(LDAPLIBS)
+ dirmngr_LDADD = $(libcommonpth) $(DNSLIBS) $(LIBASSUAN_LIBS) \
+- $(KSBA_LIBS) $(NPTH_LIBS) $(NTBTLS_LIBS) $(LIBGNUTLS_LIBS) \
+ $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) $(LIBINTL) $(LIBICONV) \
++ $(KSBA_LIBS) $(NPTH_LIBS) $(NTBTLS_LIBS) $(LIBGNUTLS_LIBS) \
+ $(NETLIBS) $(dirmngr_rc_objs) $(am__append_11)
+ dirmngr_LDFLAGS =
+ dirmngr_DEPENDENCIES = $(dirmngr_rc_objs)