aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-10-17 17:46:23 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-10-17 17:51:38 +0000
commit7fbe5fd00a138a8198b5093a5cde96b938db48ef (patch)
tree0fad3cc6840955db9cb59bbd79904eef15cca56a
parentade14c9a20f140295e58e398df0a04ee5dafff04 (diff)
downloadports-7fbe5fd00a138a8198b5093a5cde96b938db48ef.tar.gz
ports-7fbe5fd00a138a8198b5093a5cde96b938db48ef.zip
security/nss: try to fix build in unclean environment
ports like net/mpich may install a mpi.ch in ${LOCALBASE}/include and hide nss' own lib/freebl/mpi/mpi.h, resulting in build failures ("unknown type name 'mp_int'"). without a dirty environment of my own to test, this may or may not fix the issue. Reported by: Chad Jacob Milios
-rw-r--r--security/nss/Makefile2
-rw-r--r--security/nss/files/patch-nss_cmd_dbtool_manifest.mn10
2 files changed, 11 insertions, 1 deletions
diff --git a/security/nss/Makefile b/security/nss/Makefile
index 50fe4d5171df..d23227ecfc71 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -30,7 +30,7 @@ MAKE_ENV= NSPR_LIB_DIR="${LOCALBASE}/lib" \
NSS_ENABLE_WERROR=0 \
NSS_DISABLE_GTESTS=1 \
NSS_USE_SYSTEM_SQLITE=1
-CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/nspr -Wno-error=unused-function
+CFLAGS+= -I${LOCALBASE}/include/nspr -Wno-error=unused-function
SUB_FILES= nss-config nss.pc
SUB_LIST= PORTVERSION=${PORTVERSION}
diff --git a/security/nss/files/patch-nss_cmd_dbtool_manifest.mn b/security/nss/files/patch-nss_cmd_dbtool_manifest.mn
new file mode 100644
index 000000000000..a3222958cb13
--- /dev/null
+++ b/security/nss/files/patch-nss_cmd_dbtool_manifest.mn
@@ -0,0 +1,10 @@
+--- cmd/dbtool/manifest.mn.orig 2023-10-17 19:40:13.402222000 +0200
++++ cmd/dbtool/manifest.mn 2023-10-17 19:40:35.457563000 +0200
+@@ -13,6 +13,7 @@
+ # DIRS =
+
+ CSRCS = dbtool.c sdb.c
++CFLAGS += -I${SQLITE_INCLUDE_DIR}
+
+ # sdb.c is copied for softoken, clean it up on make clean
+ GARBAGE = sdb.c