aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2023-08-24 14:07:36 +0000
committerChris Rees <crees@FreeBSD.org>2023-08-24 14:09:48 +0000
commit808d491c649936e0cfb8585b4bc3a0b52b25cca8 (patch)
treee1a64b2dd109a646a448b6e6d262655621c83235
parent3459b487342b9e50a397f3cd172e35b7dc5497ee (diff)
downloadports-808d491c649936e0cfb8585b4bc3a0b52b25cca8.tar.gz
ports-808d491c649936e0cfb8585b4bc3a0b52b25cca8.zip
www/mod_authz_unixgroup24: Resurrect and update
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_authz_unixgroup24/Makefile32
-rw-r--r--www/mod_authz_unixgroup24/distinfo3
-rw-r--r--www/mod_authz_unixgroup24/pkg-descr5
4 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9daccf5d0b08..6092467b3962 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -379,6 +379,7 @@
SUBDIR += mod_auth_xradius
SUBDIR += mod_authn_dovecot
SUBDIR += mod_authnz_external24
+ SUBDIR += mod_authz_unixgroup24
SUBDIR += mod_cfg_ldap
SUBDIR += mod_cloudflare
SUBDIR += mod_dav_svn
diff --git a/www/mod_authz_unixgroup24/Makefile b/www/mod_authz_unixgroup24/Makefile
new file mode 100644
index 000000000000..2d83d920fae1
--- /dev/null
+++ b/www/mod_authz_unixgroup24/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= mod_authz_unixgroup
+PORTVERSION= 1.1.0
+CATEGORIES= www
+PKGNAMESUFFIX= 24
+DIST_SUBDIR= apache24
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Allows users authentication based on UNIX group on apache 2.4
+WWW= https://github.com/phokz/mod-auth-external/wiki/ModAuthzUnixGroup
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= apache cpe
+USE_GITHUB= yes
+GH_ACCOUNT= phokz
+GH_PROJECT= mod-auth-external
+GH_TAGNAME= ${PORTNAME}-${DISTVERSION}
+CPE_VENDOR= ${GH_PROJECT}_project
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+SHORTMODNAME= authz_unixgroup
+
+PORTDOCS= CHANGES INSTALL NOTICE README
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/www/mod_authz_unixgroup24/distinfo b/www/mod_authz_unixgroup24/distinfo
new file mode 100644
index 000000000000..883ec41f75c8
--- /dev/null
+++ b/www/mod_authz_unixgroup24/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1692881865
+SHA256 (apache24/phokz-mod-auth-external-1.1.0-mod_authz_unixgroup-1.1.0_GH0.tar.gz) = d91c7124afdbdc9373f297af8d4d9c2fb6afce483ce8a6f656dc07d8042d290b
+SIZE (apache24/phokz-mod-auth-external-1.1.0-mod_authz_unixgroup-1.1.0_GH0.tar.gz) = 10085
diff --git a/www/mod_authz_unixgroup24/pkg-descr b/www/mod_authz_unixgroup24/pkg-descr
new file mode 100644
index 000000000000..b52cdf28fe2f
--- /dev/null
+++ b/www/mod_authz_unixgroup24/pkg-descr
@@ -0,0 +1,5 @@
+Mod_Authz_Unixgroup is a unix group access control modules for Apache. If
+you are having users authenticate with real Unix login ID over the net, using
+something like my mod_authnz_external/pwauth combination, and you want to do
+access control based on unix group membership, then mod_authz_unixgroup is
+exactly what you need.