aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-11-30 13:29:18 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-11-30 13:29:18 +0000
commit80ed4eb5ea03d06791b7e9990b027559499c5a57 (patch)
treed003daaf7fd6d0435e820f8c4db6641179cf6acc
parentb491b452d35004b0078429425ba36cecdf48440e (diff)
downloadports-80ed4eb5ea03d06791b7e9990b027559499c5a57.tar.gz
ports-80ed4eb5ea03d06791b7e9990b027559499c5a57.zip
audio/praat: fix build on 14-
Build failures reported upstream at https://github.com/praat/praat/issues/1933 The build failure is in test-code, in a static function that does nothing useful -- looks like some C++-experimentation that is still in the source tree. Massage it away so that builds on 14- can happen. Bump PORTREVISION since on pre-14- it might now pick a different constructor, and so potentially the package changes.
-rw-r--r--audio/praat/Makefile1
-rw-r--r--audio/praat/files/patch-fon_Praat__tests.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/audio/praat/Makefile b/audio/praat/Makefile
index e9c592423126..3f1ac399450e 100644
--- a/audio/praat/Makefile
+++ b/audio/praat/Makefile
@@ -1,6 +1,7 @@
PORTNAME= praat
DISTVERSIONPREFIX= v
DISTVERSION= 6.2.01
+PORTREVISION= 1
CATEGORIES= audio science
MAINTAINER= adridg@FreeBSD.org
diff --git a/audio/praat/files/patch-fon_Praat__tests.cpp b/audio/praat/files/patch-fon_Praat__tests.cpp
new file mode 100644
index 000000000000..bf0c6515f662
--- /dev/null
+++ b/audio/praat/files/patch-fon_Praat__tests.cpp
@@ -0,0 +1,11 @@
+--- fon/Praat_tests.cpp.orig 2021-11-30 13:24:45 UTC
++++ fon/Praat_tests.cpp
+@@ -742,7 +742,7 @@ class Vec { (public)
+ };
+
+ static Vec copy (Vec x) {
+- return x;
++ return Vec(x);
+ }
+
+ /*static void tryVec () {