aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-11-19 11:56:28 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-11-19 11:57:10 +0000
commit8118d3170b870338954f847e964f9c0c604a3891 (patch)
treecb940f10b557f10c4eb5eb36ce7adff0dc520f5c
parentb82bbc8cd93697b5b08046fdcf2ded4f7a50f434 (diff)
downloadports-8118d3170b870338954f847e964f9c0c604a3891.tar.gz
ports-8118d3170b870338954f847e964f9c0c604a3891.zip
databases/sqlitestudio: Update 3.3.3 -> 3.4.0
Reported by: portscout
-rw-r--r--databases/sqlitestudio/Makefile9
-rw-r--r--databases/sqlitestudio/distinfo6
-rw-r--r--databases/sqlitestudio/files/patch-5e7ee1ed25222cdb193f862702d480b91d195fa938
3 files changed, 44 insertions, 9 deletions
diff --git a/databases/sqlitestudio/Makefile b/databases/sqlitestudio/Makefile
index e60e1e9cb178..4ede3c708d72 100644
--- a/databases/sqlitestudio/Makefile
+++ b/databases/sqlitestudio/Makefile
@@ -1,6 +1,5 @@
PORTNAME= sqlitestudio
-DISTVERSION= 3.3.3
-PORTREVISION= 1
+DISTVERSION= 3.4.0
CATEGORIES= databases
MAINTAINER= yuri@FreeBSD.org
@@ -29,7 +28,7 @@ PLUGIN_PRINTING_USE= QT=printsupport
USES= compiler:c++17-lang gl gmake ncurses qmake qt:5 readline sqlite
USE_GITHUB= yes
GH_ACCOUNT= pawelsalawa
-USE_QT= core concurrent gui network script sql sql-sqlite3:run svg widgets xml \
+USE_QT= core concurrent declarative gui network script sql sql-sqlite3:run svg widgets xml \
uitools buildtools:build linguisttools:build
USE_GL= gl
@@ -41,12 +40,10 @@ DESKTOP_ENTRIES= "SQLite database manager" \
"Advanced SQLite database manager" \
"SQLiteStudio" \
"SQLiteStudio" \
- "Database;Viewer;DataVisualization;Development;Qt;" \
+ "Viewer;DataVisualization;Development;Qt;" \
""
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/|${LOCALBASE}/|' \
- ${WRKSRC}/dirs.pri
@${REINPLACE_CMD} -e 's|pluginDirs += QDir(CFG->getConfigDir()).absoluteFilePath("plugins");|pluginDirs += "${LOCALBASE}/lib/sqlitestudio";|' \
${WRKSRC}/coreSQLiteStudio/services/impl/pluginmanagerimpl.cpp
diff --git a/databases/sqlitestudio/distinfo b/databases/sqlitestudio/distinfo
index c94a7cc7bb84..ba60d5afce61 100644
--- a/databases/sqlitestudio/distinfo
+++ b/databases/sqlitestudio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1619063721
-SHA256 (pawelsalawa-sqlitestudio-3.3.3_GH0.tar.gz) = f234e1ea87d27e80a1794f86d32116ebd8919d51be63d35a7d0816a77115ce31
-SIZE (pawelsalawa-sqlitestudio-3.3.3_GH0.tar.gz) = 8863232
+TIMESTAMP = 1668856780
+SHA256 (pawelsalawa-sqlitestudio-3.4.0_GH0.tar.gz) = 0295b2286b0f2830d398141341a7966dfac2748fc8792b50be0122fa7baf4a18
+SIZE (pawelsalawa-sqlitestudio-3.4.0_GH0.tar.gz) = 13149123
diff --git a/databases/sqlitestudio/files/patch-5e7ee1ed25222cdb193f862702d480b91d195fa9 b/databases/sqlitestudio/files/patch-5e7ee1ed25222cdb193f862702d480b91d195fa9
new file mode 100644
index 000000000000..caec05048c0e
--- /dev/null
+++ b/databases/sqlitestudio/files/patch-5e7ee1ed25222cdb193f862702d480b91d195fa9
@@ -0,0 +1,38 @@
+--- ../Plugins/ScriptingTcl/ScriptingTcl.pro
++++ ../Plugins/ScriptingTcl/ScriptingTcl.pro
+@@ -44,7 +44,7 @@ linux: {
+ !exists($$TCL_CONFIG) {
+ # Debian case
+ DEBIAN_ARCH_PATH=$$system(dpkg-architecture -qDEB_HOST_MULTIARCH)
+- TCL_CONFIG = /usr/lib/$$DEBIAN_ARCH_PATH/tcl$$TCL_VERSION/tclConfig.sh
++ TCL_CONFIG = $$PREFIX/lib/$$DEBIAN_ARCH_PATH/tcl$$TCL_VERSION/tclConfig.sh
+ }
+ message("Looking for $$TCL_CONFIG")
+ !exists($$TCL_CONFIG) {
+--- Tests/TestUtils/TestUtils.pro
++++ Tests/TestUtils/TestUtils.pro
+@@ -41,7 +41,7 @@ unix:!symbian {
+ maemo5 {
+ target.path = /opt/usr/lib
+ } else {
+- target.path = /usr/lib
++ target.path = $$PREFIX/lib
+ }
+ INSTALLS += target
+ }
+--- common.pri
++++ common.pri
+@@ -40,11 +40,11 @@ portable {
+
+ unix: {
+ isEmpty(LIBDIR) {
+- LIBDIR = /usr/lib
++ LIBDIR = $$PREFIX/lib
+ }
+ export(LIBDIR)
+ isEmpty(BINDIR) {
+- BINDIR = /usr/bin
++ BINDIR = $$PREFIX/bin
+ }
+ export(BINDIR)
+ }