aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-14 19:04:07 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-14 19:04:07 +0000
commit8122bb9081e5dc237bdd0a7161c8ab6b3875d324 (patch)
tree02f1fbc26353477fb1acf41a4ae6065c94b0cc75
parenteaac79f64c491d9fd7e943148b1dff86c6dfdf30 (diff)
downloadports-8122bb9081e5dc237bdd0a7161c8ab6b3875d324.tar.gz
ports-8122bb9081e5dc237bdd0a7161c8ab6b3875d324.zip
misc/valentina: fix build on armv7 / i386 / powerpc by using ld.bfd
-rw-r--r--misc/valentina/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/misc/valentina/Makefile b/misc/valentina/Makefile
index 0acba593b686..e59ae6d53e10 100644
--- a/misc/valentina/Makefile
+++ b/misc/valentina/Makefile
@@ -9,9 +9,6 @@ WWW= https://smart-pattern.com.ua/en/
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE_GPL.txt
-BROKEN_armv7= ld: error: failed to open bin/valentina: Cannot allocate memory
-BROKEN_i386= ld: error: failed to open bin/valentina: Cannot allocate memory
-
USES= compiler:c++11-lang desktop-file-utils dos2unix gl gmake qmake qt:5
USE_QT= buildtools:build concurrent core gui linguisttools:build network \
opengl printsupport svg testlib:build widgets xml xmlpatterns
@@ -31,4 +28,10 @@ QMAKE_ARGS+= CONFIG+="no_ccache"
BINARY_ALIAS= hg=/usr/bin/true git=/usr/bin/false
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == armv7 || ${ARCH} == i386 || ${ARCH} == powerpc
+LLD_UNSAFE= yes
+.endif
+
.include <bsd.port.mk>