aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2021-08-16 12:10:43 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2021-09-18 18:22:03 +0000
commit820a862e6e54a223c82fb5f82b6eb3061a7dba82 (patch)
tree0c2b63eba58eff7b166cb6b187575dd93c985e1c
parent03e35e391322633ead31d3c2ced12f23b8dbf4b2 (diff)
downloadports-820a862e6e54a223c82fb5f82b6eb3061a7dba82.tar.gz
ports-820a862e6e54a223c82fb5f82b6eb3061a7dba82.zip
net/libsrtp2: Update to 2.4.1
-rw-r--r--net/libsrtp2/Makefile2
-rw-r--r--net/libsrtp2/distinfo6
-rw-r--r--net/libsrtp2/files/patch-3a5d26c413
-rw-r--r--net/libsrtp2/files/patch-716a7386.c26
4 files changed, 17 insertions, 30 deletions
diff --git a/net/libsrtp2/Makefile b/net/libsrtp2/Makefile
index 3275f766eedc..69ae3ce21160 100644
--- a/net/libsrtp2/Makefile
+++ b/net/libsrtp2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libsrtp
DISTVERSIONPREFIX= v
-DISTVERSION= 2.3.0
+DISTVERSION= 2.4.1
CATEGORIES= net
PKGNAMESUFFIX= 2
diff --git a/net/libsrtp2/distinfo b/net/libsrtp2/distinfo
index 9dd1fbcb4dad..84a0d342e2d5 100644
--- a/net/libsrtp2/distinfo
+++ b/net/libsrtp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1581428909
-SHA256 (cisco-libsrtp-v2.3.0_GH0.tar.gz) = 94093a5d04c5f4743e8d81182b76938374df6d393b45322f24960d250b0110e8
-SIZE (cisco-libsrtp-v2.3.0_GH0.tar.gz) = 633819
+TIMESTAMP = 1631988977
+SHA256 (cisco-libsrtp-v2.4.1_GH0.tar.gz) = 3cb580928fcd502426809c68406d04aaa5ef1af7ebb0a3a41a52a13576f2fc07
+SIZE (cisco-libsrtp-v2.4.1_GH0.tar.gz) = 631328
diff --git a/net/libsrtp2/files/patch-3a5d26c4 b/net/libsrtp2/files/patch-3a5d26c4
new file mode 100644
index 000000000000..f459834f2f7d
--- /dev/null
+++ b/net/libsrtp2/files/patch-3a5d26c4
@@ -0,0 +1,13 @@
+diff --git a/srtp/srtp.c b/srtp/srtp.c
+index c7f6bb9f..dbb09909 100644
+--- srtp/srtp.c
++++ srtp/srtp.c
+@@ -788,7 +788,7 @@ static inline int full_key_length(const srtp_cipher_type_t *cipher)
+ case SRTP_AES_GCM_128:
+ return SRTP_AES_GCM_128_KEY_LEN_WSALT;
+ case SRTP_AES_GCM_256:
+- return SRTP_AES_ICM_256_KEY_LEN_WSALT;
++ return SRTP_AES_GCM_256_KEY_LEN_WSALT;
+ default:
+ return 0;
+ }
diff --git a/net/libsrtp2/files/patch-716a7386.c b/net/libsrtp2/files/patch-716a7386.c
deleted file mode 100644
index b5fe8f4442b3..000000000000
--- a/net/libsrtp2/files/patch-716a7386.c
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/crypto/math/datatypes.c b/crypto/math/datatypes.c
-index 001584c1..4fcb3965 100644
---- crypto/math/datatypes.c
-+++ crypto/math/datatypes.c
-@@ -79,7 +79,7 @@ int octet_get_weight(uint8_t octet)
-
- /* the value MAX_PRINT_STRING_LEN is defined in datatypes.h */
-
--char bit_string[MAX_PRINT_STRING_LEN];
-+static char bit_string[MAX_PRINT_STRING_LEN];
-
- uint8_t srtp_nibble_to_hex_char(uint8_t nibble)
- {
-diff --git a/test/util.c b/test/util.c
-index 2abc28e7..c0f76149 100644
---- test/util.c
-+++ test/util.c
-@@ -49,7 +49,7 @@
- #include <stdint.h>
-
- /* include space for null terminator */
--char bit_string[MAX_PRINT_STRING_LEN + 1];
-+static char bit_string[MAX_PRINT_STRING_LEN + 1];
-
- static inline int hex_char_to_nibble(uint8_t c)
- {