aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2024-01-22 12:20:47 +0000
committerWen Heping <wen@FreeBSD.org>2024-01-22 12:22:15 +0000
commit821ec0307feae79c76abb1b7176ea40cd3d3f9b9 (patch)
treea0edb5887ea1ca2ace02999dfd8210cf3ef56d3d
parent345fc748de406d65743d58178ef3f989d6a73e35 (diff)
downloadports-821ec0307feae79c76abb1b7176ea40cd3d3f9b9.tar.gz
ports-821ec0307feae79c76abb1b7176ea40cd3d3f9b9.zip
science/py-ipygany: Fix build with python-3.11
PR: 275494 Approved by: portmgr(blanket, fix build)
-rw-r--r--science/py-ipygany/files/patch-setup.py20
1 files changed, 20 insertions, 0 deletions
diff --git a/science/py-ipygany/files/patch-setup.py b/science/py-ipygany/files/patch-setup.py
new file mode 100644
index 000000000000..a33ef52cfea1
--- /dev/null
+++ b/science/py-ipygany/files/patch-setup.py
@@ -0,0 +1,20 @@
+--- setup.py.orig 2021-01-25 10:40:44 UTC
++++ setup.py
+@@ -8,7 +8,6 @@ from os import path
+ from glob import glob
+ from os import path
+
+-
+ from jupyter_packaging import (
+ create_cmdclass, install_npm, ensure_targets,
+ combine_commands, ensure_python,
+@@ -22,9 +21,6 @@ HERE = path.dirname(path.abspath(__file__))
+ name = 'ipygany'
+
+ HERE = path.dirname(path.abspath(__file__))
+-
+-# Ensure a valid python version
+-ensure_python('>=3.6')
+
+ # Get our version
+ version = get_version(path.join(name, '_version.py'))