aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2023-10-24 22:16:18 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2023-10-24 22:16:18 +0000
commit8241302dda4980341c3162f21aa8ded4e4a3b4d1 (patch)
tree7c21f9a8b38e555606ebe7e5525f26157a50b783
parent36c60a2fe7f6ffaaf92b650b7f6050c47771de57 (diff)
downloadports-8241302dda4980341c3162f21aa8ded4e4a3b4d1.tar.gz
ports-8241302dda4980341c3162f21aa8ded4e4a3b4d1.zip
emulators/wine: Improve configuration for ALSA and OSS
Use ALSA_CONFIGURE_WITH and OSS_CONFIGURE_WITH instead of the ALSA_CONFIGURE_ON and OSS_CONFIGURE_ON forms. This properly handles the case where neither the ALSA nor OSS option are set. It's more resilient to future changes. And shorter. (This back ports 944eff5cfa5f from the wine-devel port.) PR: 273987
-rw-r--r--emulators/wine/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index e79187ccad3b..50f1ca3df574 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -79,7 +79,7 @@ MONO_DESC= Bundle Mono MSI package for Wine
PORTSCOUT= limit:^8\.0
-ALSA_CONFIGURE_ON= --with-alsa --without-oss
+ALSA_CONFIGURE_WITH= alsa
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_RUN_DEPENDS= alsa-plugins>0:audio/alsa-plugins
@@ -95,7 +95,7 @@ GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
MONO_RUN_DEPENDS= wine-mono>0:emulators/wine-mono
-OSS_CONFIGURE_ON= --without-alsa --with-oss
+OSS_CONFIGURE_WITH= oss
V4L_CONFIGURE_WITH= v4l2
V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat