aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Hurst <tom@hur.st>2023-08-22 01:36:42 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-12 14:55:19 +0000
commit82f6916a4dac34ee3b4d235e74fce9e0eb6bedb4 (patch)
tree80b27d1870e905d2af6a41fed2717d94a5b6f056
parentb76776338b7c56f3c3b8d4eddd36ae7ba11099ac (diff)
downloadports-82f6916a4dac34ee3b4d235e74fce9e0eb6bedb4.tar.gz
ports-82f6916a4dac34ee3b4d235e74fce9e0eb6bedb4.zip
security/portacl-rc: Add new port
portacl-rc is an rc(8) script for mac_portacl(4), allowing administrators to limit or permit binding to local UDP and TCP ports that would otherwise be privileged to the superuser. PR: 273275
-rw-r--r--security/Makefile1
-rw-r--r--security/portacl-rc/Makefile26
-rw-r--r--security/portacl-rc/distinfo3
-rw-r--r--security/portacl-rc/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a2717e0372fd..609837e80af0 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -828,6 +828,7 @@
SUBDIR += plasma5-kwallet-pam
SUBDIR += please
SUBDIR += poly1305aes
+ SUBDIR += portacl-rc
SUBDIR += proftpd-mod_clamav
SUBDIR += proxycheck
SUBDIR += proxytunnel
diff --git a/security/portacl-rc/Makefile b/security/portacl-rc/Makefile
new file mode 100644
index 000000000000..421e748437e6
--- /dev/null
+++ b/security/portacl-rc/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= portacl-rc
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.9.0
+CATEGORIES= security net
+
+MAINTAINER= tom@hur.st
+COMMENT= RC script for mac_portacl(4)
+WWW= https://github.com/Freaky/portacl
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= Freaky
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= etc/rc.d/portacl \
+ man/man5/portacl.5.gz
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/portacl ${STAGEDIR}${PREFIX}/etc/rc.d
+ ${INSTALL_MAN} ${WRKSRC}/portacl.5 ${STAGEDIR}${MANPREFIX}/man/man5
+
+.include <bsd.port.mk>
diff --git a/security/portacl-rc/distinfo b/security/portacl-rc/distinfo
new file mode 100644
index 000000000000..9b19763ac7bf
--- /dev/null
+++ b/security/portacl-rc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1692670526
+SHA256 (Freaky-portacl-rc-v0.9.0_GH0.tar.gz) = 28603e78b33001a9b7edcc7bbf76c8894a71f32bab9d7af57751bf9d8c44507c
+SIZE (Freaky-portacl-rc-v0.9.0_GH0.tar.gz) = 57186
diff --git a/security/portacl-rc/pkg-descr b/security/portacl-rc/pkg-descr
new file mode 100644
index 000000000000..2750f99ac319
--- /dev/null
+++ b/security/portacl-rc/pkg-descr
@@ -0,0 +1,3 @@
+portacl-rc is an rc(8) script for mac_portacl(4), allowing administrators
+to limit or permit binding to local UDP and TCP ports that would otherwise
+be privileged to the superuser.