aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-11-12 04:51:20 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-11-12 04:51:47 +0000
commit835d84cce49f125c86132bae1faf6da55cd1ccea (patch)
tree205776090cbf96cd457d63c170b95bb6d05ddfb2
parent3291ad38b01250a83a64672fb5f7ed93c7b61948 (diff)
downloadports-835d84cce49f125c86132bae1faf6da55cd1ccea.tar.gz
ports-835d84cce49f125c86132bae1faf6da55cd1ccea.zip
net-im/cawbird: New port: Fork of Corebird GTK Twitter client
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/cawbird/Makefile39
-rw-r--r--net-im/cawbird/distinfo3
-rw-r--r--net-im/cawbird/files/patch-meson.build11
-rw-r--r--net-im/cawbird/pkg-descr8
-rw-r--r--net-im/cawbird/pkg-plist10
6 files changed, 72 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 0d9f039ea014..3222088cceba 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -3,6 +3,7 @@
SUBDIR += 6cord
SUBDIR += beebeep
SUBDIR += biboumi
+ SUBDIR += cawbird
SUBDIR += centerim
SUBDIR += chatterino2
SUBDIR += climm
diff --git a/net-im/cawbird/Makefile b/net-im/cawbird/Makefile
new file mode 100644
index 000000000000..c13974c86244
--- /dev/null
+++ b/net-im/cawbird/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= cawbird
+PORTVERSION= 1.4.2
+DISTVERSIONPREFIX= v
+CATEGORIES= net-im
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= Fork of Corebird GTK Twitter client
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= vala:lang/vala
+LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \
+ liboauth.so:net/liboauth \
+ librest-0.7.so:devel/librest \
+ libsoup-gnome-2.4.so:devel/libsoup
+
+USES= gnome meson pkgconfig sqlite:3
+
+USE_GITHUB= yes
+GH_ACCOUNT= IBBoard
+
+USE_GNOME= glib20 gtk30
+
+GLIB_SCHEMAS= uk.co.ibboard.cawbird.gschema.xml
+
+MESON_ARGS= -Dconsumer_key_base64=YUVNOE14dE5xMVdHRzl2emo5SzNNSlNUeg== \
+ -Dconsumer_secret_base64=c0J0cmc2clNJTFN6bHlSbFNXc2J1MmdvWWk3b0FzTGZHOGI4OG5QRzB3Tmx1Y0ZtOHQ=
+
+OPTIONS_DEFINE= SPELLCHECK VIDEO
+
+SPELLCHECK_LIB_DEPENDS= libgtkspell3-3.so:textproc/gtkspell3
+SPELLCHECK_MESON_OFF= -Dspellcheck=false
+
+VIDEO_LIB_DEPENDS= libgstvideo-1.0.so:multimedia/gstreamer1-plugins
+VIDEO_MESON_OFF= -Dvideo=false
+
+.include <bsd.port.mk>
+
diff --git a/net-im/cawbird/distinfo b/net-im/cawbird/distinfo
new file mode 100644
index 000000000000..05635e19b4e4
--- /dev/null
+++ b/net-im/cawbird/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1636688445
+SHA256 (IBBoard-cawbird-v1.4.2_GH0.tar.gz) = 4726e1c6c407d7bf4ee24fbf67a453174b7d01433277ce542354ac62e28857c0
+SIZE (IBBoard-cawbird-v1.4.2_GH0.tar.gz) = 653216
diff --git a/net-im/cawbird/files/patch-meson.build b/net-im/cawbird/files/patch-meson.build
new file mode 100644
index 000000000000..ccc651383701
--- /dev/null
+++ b/net-im/cawbird/files/patch-meson.build
@@ -0,0 +1,11 @@
+--- meson.build.orig 2021-09-19 15:58:12 UTC
++++ meson.build
+@@ -13,7 +13,7 @@ srcdir = include_directories('src')
+ # This is apparently bad practice, but it solves our "undefined reference to symbol 'floor@@GLIBC_2.2.5'" build problem
+ cc = meson.get_compiler('c')
+ libm = cc.find_library('m', required : false)
+-oauth = cc.find_library('oauth')
++oauth = cc.find_library('oauth', dirs : '/usr/local/lib', required : true)
+
+ min_glib_version = '2.44'
+
diff --git a/net-im/cawbird/pkg-descr b/net-im/cawbird/pkg-descr
new file mode 100644
index 000000000000..5ee0d9612b5f
--- /dev/null
+++ b/net-im/cawbird/pkg-descr
@@ -0,0 +1,8 @@
+Cawbird is a fork of the Corebird Twitter client from Baedert, which became
+unsupported after Twitter disabled the streaming API.
+
+Cawbird works with the new APIs and includes a few fixes and modifications
+that have historically been patched in to IBBoard's custom Corebird build
+on his personal Open Build Service account.
+
+WWW: https://github.com/IBBoard/cawbird
diff --git a/net-im/cawbird/pkg-plist b/net-im/cawbird/pkg-plist
new file mode 100644
index 000000000000..af597203f977
--- /dev/null
+++ b/net-im/cawbird/pkg-plist
@@ -0,0 +1,10 @@
+bin/cawbird
+man/man1/cawbird.1.gz
+share/dbus-1/services/uk.co.ibboard.cawbird.service
+share/icons/hicolor/16x16/apps/uk.co.ibboard.cawbird.png
+share/icons/hicolor/24x24/apps/uk.co.ibboard.cawbird.png
+share/icons/hicolor/32x32/apps/uk.co.ibboard.cawbird.png
+share/icons/hicolor/48x48/apps/uk.co.ibboard.cawbird.png
+share/icons/hicolor/64x64/apps/uk.co.ibboard.cawbird.png
+share/icons/hicolor/96x96/apps/uk.co.ibboard.cawbird.png
+share/icons/hicolor/scalable/apps/uk.co.ibboard.cawbird.svg