aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Osipov <michael.osipov@siemens.com>2023-08-31 13:15:09 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2023-09-15 12:07:41 +0000
commit83964d19d9f692d91242d53609b9005e2e5e7ac8 (patch)
treeb5acd8328e02a28b91ec47283758135df0aa5752
parent8c334081f9d29524bafb54ecffb7c43989815157 (diff)
downloadports-83964d19d9f692d91242d53609b9005e2e5e7ac8.tar.gz
ports-83964d19d9f692d91242d53609b9005e2e5e7ac8.zip
print/ghostscript10: add default port option for X11
This change replaces flavors with a new default port option for X11. Compared to GS 9 port the X11 device driver is now integrated into GS instead of being dynamically loaded which is not in conformance with new GS 10 approach. The flavors approach creates conflicting dependencies with other ports which cannot be solved this time with the ports framework. See PRs 270989 and 272541 for details. PR: 272541 Tested by: kib
-rw-r--r--UPDATING10
-rw-r--r--print/ghostscript10/Makefile25
2 files changed, 17 insertions, 18 deletions
diff --git a/UPDATING b/UPDATING
index ba4e4ca76b74..23dab47ee57f 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,16 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20230915:
+ AFFECTS: users of print/ghostscript10
+ AUTHOR: michael.osipov@siemens.com
+
+ The port flavors have been replaced with a default port option of X11.
+ The flavors approach creates conflicting dependencies with other ports which
+ cannot be solved this time with the ports framework.
+
+ See PRs 270989 and 272541 for details.
+
20230910:
AFFECTS: users of dns/powerdns
AUTHOR: tremere@cainites.net
diff --git a/print/ghostscript10/Makefile b/print/ghostscript10/Makefile
index 2150ac1d4db9..5d3004c36122 100644
--- a/print/ghostscript10/Makefile
+++ b/print/ghostscript10/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ghostscript
DISTVERSION= 10.01.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${DISTVERSION:S/.//g}/
PKGNAMESUFFIX= ${GS_MAJOR_VERSION}
@@ -24,12 +24,6 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
RUN_DEPENDS= poppler-data>=0.4.9:graphics/poppler-data \
urw-base35-fonts>=20200910:x11-fonts/urw-base35-fonts
-FLAVORS= default x11
-FLAVOR?= ${FLAVORS:[1]}
-default_CONFLICTS_INSTALL= ${PORTNAME}${GS_MAJOR_VERSION}-${FLAVORS:[2]}
-x11_PKGNAMESUFFIX= ${GS_MAJOR_VERSION}-${FLAVOR}
-x11_CONFLICTS_INSTALL= ${PORTNAME}${GS_MAJOR_VERSION}
-
USES= cpe gmake iconv jpeg localbase pkgconfig tar:xz
USE_LDCONFIG= yes
CPE_VENDOR= artifex
@@ -55,15 +49,6 @@ GNU_CONFIGURE= yes
ALL_TARGET= so
INSTALL_TARGET= soinstall
-.if ${FLAVOR} == default
-CONFIGURE_ARGS+= --without-x
-.endif
-.if ${FLAVOR} == x11
-USES+= xorg
-USE_XORG= ice sm x11 xext xt
-CONFIGURE_ARGS+= --with-x
-.endif
-
DATADIR= ${PREFIX}/share/${PORTNAME}/${DISTVERSION}
GS_MAJOR_VERSION= ${DISTVERSION:R:R}
@@ -86,8 +71,8 @@ CONFIGURE_ARGS+= --disable-compile-inits \
--with-libpaper \
--with-system-libtiff
-OPTIONS_DEFINE= CUPS IJS TESSERACT
-OPTIONS_DEFAULT= CUPS
+OPTIONS_DEFINE= CUPS IJS TESSERACT X11
+OPTIONS_DEFAULT= CUPS X11
IJS_DESC= Support libijs based Ghostscript devices
TESSERACT_DESC= Enable bundled Tesseract OCR engine
@@ -103,6 +88,10 @@ TESSERACT_CONFIGURE_WITH= tesseract
# No TESSERACT_LIB_DEPENDS= libtesseract.so:graphics/tesseract
# See https://bugs.ghostscript.com/show_bug.cgi?id=706490
+X11_CONFIGURE_WITH= x
+X11_USES= xorg
+X11_USE= xorg=ice,sm,x11,xext,xt
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${PATCH_WRKSRC}/man/gs.1