aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-12-28 20:19:54 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-12-28 23:03:32 +0000
commit83a109cf8d9c6ed937f55a3ce04da4b79b21058b (patch)
tree2d405553ef183450ac4793fc29927250f82f5332
parente95a2d4d6388482e568260f9c895b2720c6e9248 (diff)
downloadports-83a109cf8d9c6ed937f55a3ce04da4b79b21058b.tar.gz
ports-83a109cf8d9c6ed937f55a3ce04da4b79b21058b.zip
games/minetest: Fix build with CMake >= 3.28.0
PR: 275730 Approved by: portmgr (blanket)
-rw-r--r--games/minetest/files/patch-src_CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/games/minetest/files/patch-src_CMakeLists.txt b/games/minetest/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..c9391d6c1612
--- /dev/null
+++ b/games/minetest/files/patch-src_CMakeLists.txt
@@ -0,0 +1,17 @@
+Fix build with CMake >= 3.28.0. FREETYPE_LIBRARY has not officially been
+part of the user-facing interface of the FindFreetype module since CMake
+2.6.0 [1] and has only been coincidentally defined up until this point.
+
+[1] https://gitlab.kitware.com/cmake/cmake/-/commit/d18fb61c76c720ec5b1ac2cc4f30a5beaf071c33
+
+--- src/CMakeLists.txt.orig 2023-04-08 16:04:52 UTC
++++ src/CMakeLists.txt
+@@ -542,7 +542,7 @@ if(BUILD_CLIENT)
+ ${GMP_LIBRARY}
+ ${JSON_LIBRARY}
+ ${LUA_BIT_LIBRARY}
+- ${FREETYPE_LIBRARY}
++ ${FREETYPE_LIBRARIES}
+ ${PLATFORM_LIBS}
+ )
+ if(NOT USE_LUAJIT)