aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 19:13:39 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 19:13:39 +0000
commit83a62584dad05ed1dc621f776eeeacbc8a283dd2 (patch)
tree75d091dc5a56bbd4272d0b6a6f11dc2b036db774
parent639b8ff516a5d6a43d7493442d8ac0c452c19ab9 (diff)
downloadports-83a62584dad05ed1dc621f776eeeacbc8a283dd2.tar.gz
ports-83a62584dad05ed1dc621f776eeeacbc8a283dd2.zip
devel/py-flit: Update to 3.4.0
-rw-r--r--devel/py-flit/Makefile5
-rw-r--r--devel/py-flit/distinfo6
-rw-r--r--devel/py-flit/files/setup.py13
3 files changed, 12 insertions, 12 deletions
diff --git a/devel/py-flit/Makefile b/devel/py-flit/Makefile
index e2af4cce8307..a608e35b0d2d 100644
--- a/devel/py-flit/Makefile
+++ b/devel/py-flit/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= flit
-PORTVERSION= 3.3.0
+PORTVERSION= 3.4.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +15,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>=0:textproc/py-docutils@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}flit-core>=${PORTVERSION}:devel/py-flit-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}toml>=0:textproc/py-toml@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}tomli>=0:textproc/py-tomli@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tomli_w>=0:textproc/py-tomli_w@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
diff --git a/devel/py-flit/distinfo b/devel/py-flit/distinfo
index f8c8b31a360f..41d22c689106 100644
--- a/devel/py-flit/distinfo
+++ b/devel/py-flit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1628103106
-SHA256 (flit-3.3.0.tar.gz) = 65fbe22aaa7f880b776b20814bd80b0afbf91d1f95b17235b608aa256325ce57
-SIZE (flit-3.3.0.tar.gz) = 117809
+TIMESTAMP = 1634111740
+SHA256 (flit-3.4.0.tar.gz) = 390288b27d89a084a32fc40020ad953e14bc215c5a01e6eb6ab8c9bdbcc57283
+SIZE (flit-3.4.0.tar.gz) = 120418
diff --git a/devel/py-flit/files/setup.py b/devel/py-flit/files/setup.py
index e11df8b4a5b7..8c5b91fc0cb5 100644
--- a/devel/py-flit/files/setup.py
+++ b/devel/py-flit/files/setup.py
@@ -10,22 +10,21 @@ package_data = \
{'': ['*'], 'flit': ['license_templates/*']}
install_requires = \
-['flit_core>=3.3.0', 'requests', 'docutils', 'toml']
+['flit_core >=3.4.0', 'requests', 'docutils', 'tomli', 'tomli-w']
extras_require = \
-{":python_version == '3.5'": ['zipfile36'],
- 'doc': ['sphinx', 'sphinxcontrib_github_alt', 'pygments-github-lexers'],
+{'doc': ['sphinx', 'sphinxcontrib_github_alt', 'pygments-github-lexers'],
'test': ['testpath', 'responses', 'pytest>=2.7.3', 'pytest-cov']}
entry_points = \
{'console_scripts': ['flit = flit:main']}
setup(name='flit',
- version='3.3.0',
+ version='3.4.0',
description='A simple packaging tool for simple packages.',
- author='Thomas Kluyver',
- author_email='thomas@kluyver.me.uk',
- url='https://flit.readthedocs.io/en/latest/',
+ author=None,
+ author_email='Thomas Kluyver <thomas@kluyver.me.uk>',
+ url=None,
packages=packages,
package_data=package_data,
install_requires=install_requires,