aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichiel van Baak Jansen <michiel@vanbaak.eu>2022-02-14 04:36:17 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2022-02-14 04:38:56 +0000
commit83c9167ae596f9fb8a6c054e07291c00a692d057 (patch)
treec49438d84feeafe1fdce957d479666e28d23b874
parent06c47417d19b08a12037ca75ea056202355c89c9 (diff)
downloadports-83c9167ae596f9fb8a6c054e07291c00a692d057.tar.gz
ports-83c9167ae596f9fb8a6c054e07291c00a692d057.zip
net-p2p/bazarr-devel: Read package_info to be inline with the other *arrs
radarr, sonarr, lidarr and prowlarr read package info from a file package_info. bazarr has this functionality as well, and this patch implements this in the FreeBSD package. This info is shown in the status page, and helps with support questions. PR: 261897
-rw-r--r--net-p2p/bazarr-devel/Makefile9
-rw-r--r--net-p2p/bazarr-devel/files/bazarr.in2
-rw-r--r--net-p2p/bazarr-devel/files/package_info.in5
3 files changed, 13 insertions, 3 deletions
diff --git a/net-p2p/bazarr-devel/Makefile b/net-p2p/bazarr-devel/Makefile
index ef4afab32b54..5454e09678bb 100644
--- a/net-p2p/bazarr-devel/Makefile
+++ b/net-p2p/bazarr-devel/Makefile
@@ -1,6 +1,7 @@
PORTNAME= bazarr
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.3-beta.28
+PORTREVISION= 1
CATEGORIES= net-p2p python
MASTER_SITES= https://github.com/morpheus65535/bazarr/releases/download/${DISTVERSIONPREFIX}${DISTVERSION}/
PKGNAMESUFFIX= -devel
@@ -23,7 +24,10 @@ USES= python:3.7+ zip
USE_RC_SUBR= bazarr
+SUB_FILES= ${PORTNAME} package_info
SUB_LIST= PYTHON_CMD=${PYTHON_CMD} \
+ MAINTAINER=${MAINTAINER} \
+ PKGVERSION=${PKGVERSION} \
USERS=${USERS}
NO_WRKSUBDIR= yes
@@ -36,10 +40,11 @@ do-build:
@${PYTHON_CMD} -O -m compileall ${WRKSRC}
do-install:
- ${INSTALL} -d -m 755 ${STAGEDIR}/${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}/${DATADIR}
+ ${INSTALL} -d -m 755 ${STAGEDIR}/${DATADIR}/bin/
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}/${DATADIR}/bin/
post-install:
+ ${INSTALL_DATA} ${WRKDIR}/package_info ${STAGEDIR}/${DATADIR}/
@${FIND} -s ${STAGEDIR} -not -type d | ${SORT} | \
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
diff --git a/net-p2p/bazarr-devel/files/bazarr.in b/net-p2p/bazarr-devel/files/bazarr.in
index 15c226c3d2d0..0202ec49d196 100644
--- a/net-p2p/bazarr-devel/files/bazarr.in
+++ b/net-p2p/bazarr-devel/files/bazarr.in
@@ -29,7 +29,7 @@ load_rc_config ${name}
pidfile="${bazarr_datadir}/bazarr.pid"
procname="%%PYTHON_CMD%%"
command="/usr/sbin/daemon"
-command_args="-f -p ${pidfile} ${procname} %%DATADIR%%/bazarr.py --no-update -c ${bazarr_datadir}"
+command_args="-f -p ${pidfile} ${procname} %%DATADIR%%/bin/bazarr.py --no-update -c ${bazarr_datadir}"
start_precmd=bazarr_precmd
bazarr_precmd()
diff --git a/net-p2p/bazarr-devel/files/package_info.in b/net-p2p/bazarr-devel/files/package_info.in
new file mode 100644
index 000000000000..4c9d2e0dcbfe
--- /dev/null
+++ b/net-p2p/bazarr-devel/files/package_info.in
@@ -0,0 +1,5 @@
+PackageVersion=%%PKGVERSION%%
+PackageAuthor=%%MAINTAINER%%
+UpdateMethod=External
+UpdateMethodMessage=use 'pkg upgrade' or [create a PR](https://bugs.freebsd.org/bugzilla/enter_bug.cgi?component=Individual%20Port%28s%29&product=Ports%20%26%20Packages) requesting an update of the port
+Branch=development