aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-31 18:43:19 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-31 18:43:19 +0000
commit8431b2352b21d7f9133ae2dc43c8ae59f0889380 (patch)
tree98c807743dbe7ffef98a26f1e835f50043931cbf
parent92886a709485a72510181444af1ac72b0d2cf9b3 (diff)
downloadports-8431b2352b21d7f9133ae2dc43c8ae59f0889380.tar.gz
ports-8431b2352b21d7f9133ae2dc43c8ae59f0889380.zip
devel/rubygem-google-apis-iam_v1050: Add rubygem-google-apis-iam_v1050 0.50.0
This is a simple client library for version V1 of the Identity and Access Management (IAM) API. It provides: - A client object that connects to the HTTP/JSON REST endpoint for the service. - Ruby objects for data structures related to the service. - Integration with the googleauth gem for authentication using OAuth, API keys, and service accounts. - Control of retry, pagination, and timeouts.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-google-apis-iam_v1050/Makefile23
-rw-r--r--devel/rubygem-google-apis-iam_v1050/distinfo3
-rw-r--r--devel/rubygem-google-apis-iam_v1050/pkg-descr7
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7728479a6187..a3fc3f6b2754 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7025,6 +7025,7 @@
SUBDIR += rubygem-google-apis-drive_v3
SUBDIR += rubygem-google-apis-generator
SUBDIR += rubygem-google-apis-iam_v1
+ SUBDIR += rubygem-google-apis-iam_v1050
SUBDIR += rubygem-google-apis-iam_v2
SUBDIR += rubygem-google-apis-iam_v2beta
SUBDIR += rubygem-google-apis-iamcredentials_v1
diff --git a/devel/rubygem-google-apis-iam_v1050/Makefile b/devel/rubygem-google-apis-iam_v1050/Makefile
new file mode 100644
index 000000000000..50e4410c00bf
--- /dev/null
+++ b/devel/rubygem-google-apis-iam_v1050/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= google-apis-iam_v1
+PORTVERSION= 0.50.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 050
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple REST client for Identity and Access Management (IAM) API V1
+WWW= https://github.com/googleapis/google-api-ruby-client/tree/main/generated/google-apis-iam_v1 \
+ https://github.com/googleapis/google-api-ruby-client
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-google-apis-core>=0.11.0<2.0:devel/rubygem-google-apis-core
+
+USES= gem
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^0\.50\.
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-google-apis-iam_v1050/distinfo b/devel/rubygem-google-apis-iam_v1050/distinfo
new file mode 100644
index 000000000000..38a9e25d7871
--- /dev/null
+++ b/devel/rubygem-google-apis-iam_v1050/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1711860467
+SHA256 (rubygem/google-apis-iam_v1-0.50.0.gem) = e236e9178ee1cb130f66386ccb8a899eef4bba46f6b99ddca3e3ea9f1793612c
+SIZE (rubygem/google-apis-iam_v1-0.50.0.gem) = 52736
diff --git a/devel/rubygem-google-apis-iam_v1050/pkg-descr b/devel/rubygem-google-apis-iam_v1050/pkg-descr
new file mode 100644
index 000000000000..7fcfa2f02f30
--- /dev/null
+++ b/devel/rubygem-google-apis-iam_v1050/pkg-descr
@@ -0,0 +1,7 @@
+This is a simple client library for version V1 of the Identity and Access
+Management (IAM) API. It provides:
+- A client object that connects to the HTTP/JSON REST endpoint for the service.
+- Ruby objects for data structures related to the service.
+- Integration with the googleauth gem for authentication using OAuth, API keys,
+ and service accounts.
+- Control of retry, pagination, and timeouts.