aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2022-10-15 01:18:28 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2022-10-15 01:18:28 +0000
commit84778f95757e53e2b2bb7bb7a24e9a9fda2b60a6 (patch)
treed4e876be5fbaf51b964d0b979f7e715e80f3ff3b
parent499d9dac7b581a371bca78bcbfb643eed7c86cbf (diff)
downloadports-84778f95757e53e2b2bb7bb7a24e9a9fda2b60a6.tar.gz
ports-84778f95757e53e2b2bb7bb7a24e9a9fda2b60a6.zip
security/snort: Use USES=luajit (defaults to luajit-devel)
-rw-r--r--security/snort/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index dd6253f56352..52ca41aa7cb7 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -1,5 +1,6 @@
PORTNAME= snort
PORTVERSION= 2.9.20
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://snort.org/downloads/snort/ \
https://snort.org/downloads/archive/snort/
@@ -77,8 +78,8 @@ FILEINSPECT_CONFIGURE_ENABLE= file-inspect
BARNYARD_RUN_DEPENDS= barnyard2:security/barnyard2
PULLEDPORK_RUN_DEPENDS= pulledpork.pl:security/pulledpork
-APPID_LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
-APPID_CONFIGURE_ENV+= luajit_CFLAGS="-I${LOCALBASE}/include/luajit-2.1" \
+APPID_USES= luajit
+APPID_CONFIGURE_ENV+= luajit_CFLAGS="-I${LUAJIT_INCDIR}" \
luajit_LIBS="-L${LOCALBASE}/lib -lluajit-5.1"
# Disable SIMD on 32-bit arm. Snort has numerous arbitrarily misaligned memory