aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2021-07-07 14:40:03 +0000
committerMathieu Arnold <mat@FreeBSD.org>2021-07-07 14:40:51 +0000
commit8480d9c37392303da97ff79a7ebdac4dc67592dd (patch)
tree9b07bf51395a607d43c4737d73067c8706a31ea5
parent79ec777c0efb46a8f4e813187f5de9a43d92f549 (diff)
downloadports-8480d9c37392303da97ff79a7ebdac4dc67592dd.tar.gz
ports-8480d9c37392303da97ff79a7ebdac4dc67592dd.zip
dns/bind9-devel: Update to latest commit.
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl20
-rw-r--r--dns/bind9-devel/pkg-plist1
4 files changed, 15 insertions, 16 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 2e8899b7d321..45a2b3c5779b 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -49,13 +49,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.17.15a0.2021.06.28
+ISCVERSION= 9.17.15a0.2021.07.06
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= f4c4217eec2a8422c9af89833602c5353bd61ebe
+GL_COMMIT= f663701b1deab34415f86cfef4172ac71e164edc
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index efcf46e01291..0d95430036d5 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1624884774
-SHA256 (isc-projects-bind9-f4c4217eec2a8422c9af89833602c5353bd61ebe_GL0.tar.gz) = 9567f413d97559e3c36cfc9b58a37b852b05c192b5d98ab46f4c012220aece25
-SIZE (isc-projects-bind9-f4c4217eec2a8422c9af89833602c5353bd61ebe_GL0.tar.gz) = 6207827
+TIMESTAMP = 1625573711
+SHA256 (isc-projects-bind9-f663701b1deab34415f86cfef4172ac71e164edc_GL0.tar.gz) = 6e07498a88a5c1525570e777501d96cbad3e9bf7d997fdb4a4da25183bec5663
+SIZE (isc-projects-bind9-f663701b1deab34415f86cfef4172ac71e164edc_GL0.tar.gz) = 6222198
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 8595891cf1c1..0814e1d03ccd 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,18 +1,18 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2021-06-28 10:15:12 UTC
+--- bin/named/config.c.orig 2021-07-06 05:53:30 UTC
+++ bin/named/config.c
@@ -179,6 +179,7 @@ options {\n\
notify-source *;\n\
notify-source-v6 *;\n\
nsec3-test-zone no;\n\
+ override-cache-ttl 0; /* do not override */\n\
+ parental-source *;\n\
+ parental-source-v6 *;\n\
provide-ixfr true;\n\
- qname-minimization relaxed;\n\
- query-source address *;\n\
---- bin/named/server.c.orig 2021-06-28 10:15:12 UTC
+--- bin/named/server.c.orig 2021-07-06 05:53:30 UTC
+++ bin/named/server.c
-@@ -4498,6 +4498,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4497,6 +4497,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2021-06-28 10:15:12 UTC
+--- lib/dns/include/dns/view.h.orig 2021-07-06 05:53:30 UTC
+++ lib/dns/include/dns/view.h
@@ -154,6 +154,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2021-06-28 10:15:12 UTC
+--- lib/dns/resolver.c.orig 2021-07-06 05:53:30 UTC
+++ lib/dns/resolver.c
-@@ -6387,6 +6387,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
+@@ -6386,6 +6386,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
/*
@@ -49,9 +49,9 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2021-06-28 10:15:12 UTC
+--- lib/isccfg/namedconf.c.orig 2021-07-06 05:53:30 UTC
+++ lib/isccfg/namedconf.c
-@@ -2028,6 +2028,7 @@ static cfg_clausedef_t view_clauses[] = {
+@@ -2029,6 +2029,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
{ "max-acache-size", NULL, CFG_CLAUSEFLAG_ANCIENT },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index feb3697570fc..691e7e9f1cac 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -184,7 +184,6 @@ include/isc/offset.h
include/isc/once.h
include/isc/os.h
include/isc/parseint.h
-include/isc/platform.h
include/isc/pool.h
include/isc/portset.h
include/isc/print.h