aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-26 12:34:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-26 13:45:26 +0000
commit84a158747282c0907692885bf7b6026d845edbc4 (patch)
treeae34c0d2db79b5b3b2b3d7d1e0f2a70cc838a219
parent75bf72ea4b2103b7009e65305bb4979023442e11 (diff)
downloadports-84a158747282c0907692885bf7b6026d845edbc4.tar.gz
ports-84a158747282c0907692885bf7b6026d845edbc4.zip
devel/py-pytest-flakes: add missing dependency
This also fixes testing for ports which depend on this Reported by: reprise Approved by: portmgr blanket
-rw-r--r--devel/py-pytest-flakes/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/py-pytest-flakes/Makefile b/devel/py-pytest-flakes/Makefile
index 46477cfb87d3..aeed86173a3c 100644
--- a/devel/py-pytest-flakes/Makefile
+++ b/devel/py-pytest-flakes/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pytest-flakes
PORTVERSION= 4.0.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pytest4-flakes
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.8.0:devel/py-pytest@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.8.0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyflakes>=0:devel/py-pyflakes@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= distutils autoplist